Spanish Notificación Push ERROR!

gainax00

Member
siguiendo el ejemplo de erel, de notificaciones (https://www.b4x.com/android/forum/t...-messages-firebase-cloud-messaging-fcm.67716/)
seguí todos los pasos pero me salta este error,


qwqw.png

la APP se cierra automáticamente
actualice el B4a al 10 pensando que seria por la versión pero... fallo!!!,
asdasd.png


me regrese a la 8
para seguir probando y nada...
alguien sabe que falla?
según: B4J-SendingTool.zip
se envía la notificación pero no puedo saber si llega la notificación puesto que la app se cierra nunca queda abierta
alguien tendrá una solución??
 

José J. Aguilar

Expert
Licensed User
Hola gainax00:

Lo primero que debes hacer es actualizar a la versión 10.5 y actualizar el SDK y toda la instalación tal y como muestra las instrucciones de instalación, ya que ha habido modificaciones, y hay que usar B4A 8+ para que las notificaciones funcionen cuando la app está en background.

Sigue cuidadosamente las instrucciones:

Ten en cuenta que hay varios post en el foro indicando este problema, y en casi todos la solución empieza por actualizar los requerimientos. (path al SDK, manifiesto, etc...)
Una vez que tengas todo actualizado y hayas seguido los pasos correctamente, vemos qué error recibes, que el error que recibes (maven artifact...) parece estar también relacionado con el SDK.

Por favor, pega también los errores como texto, no como imágenes, ya que así la búsqueda del foro puede encontrar errores similares si a alguien más le pasa.

saludos,
 

gainax00

Member
Hola gainax00:

Lo primero que debes hacer es actualizar a la versión 10.5 y actualizar el SDK y toda la instalación tal y como muestra las instrucciones de instalación, ya que ha habido modificaciones, y hay que usar B4A 8+ para que las notificaciones funcionen cuando la app está en background.

Sigue cuidadosamente las instrucciones:

Ten en cuenta que hay varios post en el foro indicando este problema, y en casi todos la solución empieza por actualizar los requerimientos. (path al SDK, manifiesto, etc...)
Una vez que tengas todo actualizado y hayas seguido los pasos correctamente, vemos qué error recibes, que el error que recibes (maven artifact...) parece estar también relacionado con el SDK.

Por favor, pega también los errores como texto, no como imágenes, ya que así la búsqueda del foro puede encontrar errores similares si a alguien más le pasa.

saludos,

....

Ahora falla el googleservices

Generating R file. Error
c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res\values\base_attrs.xml:11: error: Attribute "buttonSize" already defined with incompatible format.
c:\android\tools\..\extras\b4a_remote\com\google\android\gms\play-services-base\17.5.0\unpacked-play-services-base-17.5.0\res\values\values.xml:48: Original attribute defined here.
c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res\values\base_attrs.xml:16: error: Attribute "colorScheme" already defined with incompatible format.
c:\android\tools\..\extras\b4a_remote\com\google\android\gms\play-services-base\17.5.0\unpacked-play-services-base-17.5.0\res\values\values.xml:56: Original attribute defined here.
c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res\values\common_attrs.xml:13: error: Attribute "imageAspectRatioAdjust" already defined with incompatible format.
c:\android\tools\..\extras\b4a_remote\com\google\android\gms\play-services-base\17.5.0\unpacked-play-services-base-17.5.0\res\values\values.xml:35: Original attribute defined here.

Organizing libraries. (0.00s)
(AndroidX SDK)
Generating R file. Error
ERROR: resource directory 'c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res' does not exist

algún consejo??
 

gainax00

Member
....

Ahora falla el googleservices

Generating R file. Error
c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res\values\base_attrs.xml:11: error: Attribute "buttonSize" already defined with incompatible format.
c:\android\tools\..\extras\b4a_remote\com\google\android\gms\play-services-base\17.5.0\unpacked-play-services-base-17.5.0\res\values\values.xml:48: Original attribute defined here.
c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res\values\base_attrs.xml:16: error: Attribute "colorScheme" already defined with incompatible format.
c:\android\tools\..\extras\b4a_remote\com\google\android\gms\play-services-base\17.5.0\unpacked-play-services-base-17.5.0\res\values\values.xml:56: Original attribute defined here.
c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res\values\common_attrs.xml:13: error: Attribute "imageAspectRatioAdjust" already defined with incompatible format.
c:\android\tools\..\extras\b4a_remote\com\google\android\gms\play-services-base\17.5.0\unpacked-play-services-base-17.5.0\res\values\values.xml:35: Original attribute defined here.

Organizing libraries. (0.00s)
(AndroidX SDK)
Generating R file. Error
ERROR: resource directory 'c:\android\extras\google\google_play_services\libproject\google-play-services_lib\res' does not exist

algún consejo??
Me auto contesto:

La "falla" se corrije con:
#AdditionalJar: com.google.android.gms:play-services-ads
en lugar de:
c:\android\extras\google\google_play_services\libproject\google-play-services...
 
Top