Android Question Object reference not set to an instance of an object (just reporting, seems solved)

Ronomega73

Member
Licensed User
Got this error: Object reference not set to an instance of an object. The affected line of code worked ok before an improper shutdown (due to brownout). It's a variable of a user type that won't accept assignment of any valid values or other variables (but instead shows the red zigzag lines). After trying other things to no avail, I renamed it (minor change, from Type UserInfo to Type UserInfo1), the error disappeared. Strange. Just posting this in case someone else will experience the same problem.

EDIT: Sorry for this report, it's actually all my fault. Learned the true reason for the error later after I read Erel's comments in one of the posts of this same error that the problem was actually a similar Activity name! I both have UserInfo as type name and an activity name! No wonder why when I changed it to Type UserInfo1 the error disappeared!

My wife often complains about my inability to quickly find the things I am looking for (which actually are all under my not-so-long nose, while she on the other hand finds it quite quickly). I never thought I would have the same problem in programming. :(

Sorry for any hassle this report has brought.
 
Last edited:
Top