Android Question Playstore Services Vers.25 error

Discussion in 'Android Questions' started by kohle, Jun 26, 2015.

Similar threads

B4A Tutorial Integrating Firebase Services
B4A Library DJI Drones
B4A Tutorial Google Maps Android v2 tutorial
B4A Library Fingerprint Authentication
B4A Code Snippet Theme Colors
B4A Code Snippet Full Screen Theme
  1. kohle

    kohle Active Member Licensed User

    I updaded the playstore services to vers. 25.
    Now I get an error at start :

    java.lang.IllegalStateException: The meta-data tag in your app's AndroidManifest.xml does not have the right value. Expected 7327000 but found 7571000. You must have the following declaration within the <application> element: <meta-data android:name="com.google.android.gms.version" android:value="@Integer/google_play_services_version" />

    Manifest looks like

    AddManifestText(
    <uses-sdk android:minSdkVersion="9" android:targetSdkVersion="14"/>
    <supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
    SetApplicationAttribute(android:icon, "@drawable/icon")
    SetApplicationAttribute(android:label, "$LABEL$")
    SetApplicationAttribute(android:theme, "@android:style/Theme.Holo")
    'End of default text.
    AddApplicationText(<meta-data
    android:name="com.google.android.gms.version"
    android:value="@Integer/google_play_services_version" />)
    AddApplicationText(<meta-data
    android:name="com.google.android.maps.v2.API_KEY"
    android:value="XXXXXXX"/>
    <meta-data android:name="com.google.android.gms.version"
    android:value="@Integer/google_play_services_version"
    />)

    ' you must add one of these two permissions
    ' the permission you add will define the accuracy of location updates
    AddPermission(android.permission.ACCESS_FINE_LOCATION)
    AddPermission(android.permission.ACCESS_NETWORK_STATE)
    ' AddPermission(android.permission.ACCESS_COARSE_LOCATION)
     
  2. NJDude

    NJDude Expert Licensed User

    Have you also copied the JAR to your additional libs folder?
     
    Last edited: Jun 26, 2015
    lemonisdead and thedesolatesoul like this.
  3. kohle

    kohle Active Member Licensed User

    I forgot. Now the manifest error is gone,

    but now I have an other error. I had this once, but I dont remember what I did.

    B4A version: 5.02
    Parsing code. (0.05s)
    Compiling code. (0.12s)
    Compiling layouts code. (0.01s)
    Generating R file. (0.23s)
    Compiling generated Java code. Error
    B4A line: 431
    FusedLocationProvider1.CheckLocationSettings(Loca
    javac 1.8.0_40
    src\jk\radar\sv_gps.java:389: error: cannot access LocationSettingsRequest
    _fusedlocationprovider1.CheckLocationSettings(_locationsettingsrequestbuilder1.Build());
    ^
    class file for com.google.android.gms.location.LocationSettingsRequest not found
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice