Problem with .scv file and Greek encoding..

Discussion in 'Questions (Windows Mobile)' started by sosimple, Dec 26, 2008.

  1. sosimple

    sosimple Member

    Hi. I have write some code fore a program , which read and write some data to a data.csv file. The problem is that if a write a name in Greek eg "Παυλος" , the name in the csv file is stored with something like "ΑμοιΟΞΏΟ" . If I create the data.csv file with excel and write the name in Greeks , then the textbox of the code of basic for ppc print nothing.. I have write 500 lines of code of a program i am writing, and i have stuck to this problem..
    Is there anything i can do?
    Thanks,
     
  2. Cableguy

    Cableguy Expert Licensed User

    First of all, you posted in the wrong sub-Forum..
    this should be in "questions & Answers" and Not in "samples & Tips"...
    Second, you need to make sure your csv file is in UTF8 format...
    Do some search in the Q&A as this is an issue too many times adressed..
     
  3. sosimple

    sosimple Member

    Sorry , i first write it and then i understood that i write it in wrong sub-Forum..
    If any moderator see it please put it in the right forum.
    I already search but i didnt find a solution. I'll search again..
     
  4. Cableguy

    Cableguy Expert Licensed User

    CSV files are plain textfiles in wich each line is composed by a serios of values seperated by a marker, usually a comma thus the name: Comma Seperated Values...
    Is your csv file created BY your program, or does you program take an existing csv file?
    In the first case, the file should already be un UTF8(UTF16 actually) as it is the enciding used by B4PPC, but if you are editing an existing file and only reading or appending data to it, you must certify it to be UTF8 encoded.
    To make sure of this, opens your csv file in wordpad, and do a save as....You see among the options, an encoding field...Usually it is saved as ascii, so the missmatch characters...
     
    Last edited: Dec 26, 2008
  5. sosimple

    sosimple Member

    Ok thanks, i found a solution. I was creating the .csv file with excel and i had this problem. If i create .csv file with notepad the problem does non exist..
    I still have the problem to read this by excel... Because in excel, the names still looks like Chinese... But this is problem of excel and i'll try to find a solution for this.. Thanks again.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice