B4R Question ...same problem with RFID [solved]

Hans- Joachim Krahe

Active Member
Licensed User
Programm worked fine since 2016, but suddenly raises error:

E:\Entwicklung\B4R\TuerProjekte\D1_W_Tuer\Objects\bin\sketch\B4RDefines.h:22:17: fatal error: SPI.h: No such file or directory

... similar to thread: https://www.b4x.com/android/forum/threads/mfrc522-rfid-reader-writer.67160/#content

trying sample code comes out this error :


In file included from AsyncStreams.cpp:1:0:
B4RDefines.h:21:17: fatal error: SPI.h: No such file or directory
#include <SPI.h>
^
compilation terminated.
Errore durante la compilazione


i solved loading the source code into the arduino ide and adding :
#include <SPI.h>

in the scr.ino file

but this is a workaround and not "the solution" , where B4R compiler miss or where i miss ?

Thanks !

in attach the project

Attached Files:
coslad, Aug 10, 2016
Coslad solved with installing Version 1.6.9; I got 1.6.23 - same error with 1.6.9

reason must be different:-(

thanks for help and inspiration:)
 

Hans- Joachim Krahe

Active Member
Licensed User
thank you, spi is in stack. I installed compiler in same constellation new on other pc and it works. Maybe, I'll find out the difference...


... ok, needed to update arduino win and reboot:)
 
Last edited:
Top