working with AirPush or leadbolt libs

Discussion in 'Android Questions' started by melamoud, Nov 17, 2012.

  1. melamoud

    melamoud Active Member Licensed User

    SSG, or anyone

    I need help, I'm trying to deploy a notification ad lib, and I'm doing something wrong, or the SDK changed and it wont work with the current libs any more

    does anyone know how to make it work ?
    In airpush I'm in the deployment phase, I cant get the IDE to see the two libs (just one of them)
    in leadbolt I managed to fix all the instructions, I think and I'm just getting excpetions when I run the app.

    thanks
     
  2. susu

    susu Well-Known Member Licensed User

    I don't use Leadbolt anymore because their impression is very low for my country.

    With AirPush you need to write a wrapper to use it. If you can't write it by yourself, let's ask Bill (@Ssg) he will do it for you with a very cheap fee.
     
  3. JimmyNeutron

    JimmyNeutron New Member

    Hey, I have integrated both together in one App and haven't had any issues. However, as LeadBolt provides its own B4A wrapper i found it easier to integrate and they offered a lot more ad types which I found more beneficial.

    If you can show the exceptions you are getting, I'd be happy to take a look and help you out?
     
  4. melamoud

    melamoud Active Member Licensed User

    Jimmy thanks,
    the instructions for leadbolt are just old, for example

    they are asking to copy thier androidmanifest.xml to the lib folder
    also the file pubxapp.jar does not have an xml right ? does it need one ?
    and there is no LeadboltController.jar c in the zip files (as the readme states), etc....

    anyway after trying to figure out whats right and whats wrong, I got this error
    Code:
    Compiling code.                         0.10
    Using existing AndroidManifest.xml.
    (Project - 
    Do Not Overwrite Manifest option is checked)
    AndroidManifest-Example.xml 
    file will be created instead.
    Compiling layouts code.                 
    0.01
    Generating R 
    file.                      0.50
    Compiling generated Java code.          Error
    javac 
    1.7.0_07
    javac: 
    file not found: gen\b4a\example\R.java
    Usage: javac <options> <source files>
    use -help 
    for a list of possible options
    it seems like conf error on thier part the R.java file exists on
    ...Objects\gen\com\myb4android\MyFirstBasic4Ads\R.java not the folder they claim it should be (or is it B4A expect it there)?



    anyway AirPush I can only get MESAPLib in the IDE, I do not have an xml file for the other JAR (the SDK one that they generate specifically for me with my API KEY)

    Thanks
     
  5. JimmyNeutron

    JimmyNeutron New Member

    Hey,

    I think you maybe using the older version of the B4A Wrapper from LeadBolt. With the new wrapper there is no LeadboltController.jar file anymore. You need to use the pubiapp.jar, pubxapp.jar and pubxappCom.jar files.

    With the new wrapper there are 2 separate Wrappers - LeadboltIWrapper.jar which is for banners, overlays, etc... and the LeadboltXWrapper.jar, which is for Notifications and Icon Ads.

    I think you should download the latest version from the Leadbolt portal and follow the readme to integrate the new wrapper.
     
  6. melamoud

    melamoud Active Member Licensed User

    I have the new lib. with the right jars, I was just pointing out that the readme / instruction file gives the wrong insturcution with the wrong jar names,
     
  7. daniel69

    daniel69 Member Licensed User

    Hi "MelaMoud" ... I think you are doing better than me ... in AirPush 5.0 I get an error in the initialization phase ... ap.Initialize("myid", True, True, False) ... any idea?
     
  8. melamoud

    melamoud Active Member Licensed User

    Daniel


    Its fully working for me now !!
    But you need to create a wrapper for it with your sdk.

    You can ask ssg to make it for you for a small fee. It worked for me..
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice