B4J Question [ABMaterial] ABMFileManager 4.51 working only with 4.30 library

MichalK73

Active Member
Licensed User
Longtime User
I do not know if it owes a new version of B4J 7.00, but ABMFileManager (4.51) has stopped working. Only the file upload function works, after that nothing from the add-on. Strangely, as in B4J, I change to a library from 4.30 (ABMaterial.jar and others) and in the application I leave the www library with 4.51 it works. This can be seen even in DEMO 4.51. Can someone confirm or not change B4J?
 

alwaysbusy

Expert
Licensed User
Longtime User
There are three cases in the feedback reporting something with the filemanger, but I never got a straight answer what exactly was wrong and there was no way I could reproduce it. Maybe check the feedback app (search for filemanager) and see if it is related.

If so, please give some concrete step-by-step how I can reproduce it, because I could not.
 
Upvote 0

alwaysbusy

Expert
Licensed User
Longtime User
Here is a video of me starting from scratch (downloading the zip, unzipping, copying the library fies to the B4J folder, starting the demo, going to filemanger):

http://gorgeousapps.com/abm451FileManager.wmv

(Once the unzipping starts, you can skip to approx 03:15)

I did comment the line that automatically opens the browser as I wanted to show you the manual process with the console open. Also note that I have checked the 'disable cache' box in the console so I was sure I'm using the js/css/fonts folders and not some cached ones.

Seems to work just fine to me. You must somehow have a mixed js/css/fonts folder. All I can say is re-download the zip, copy the js/css/fonts folders from the DEMO folder (as this proves to works in my video) and try again.

Note: in your video you ONLY switch libries, not the js/css/fonts folders. It is very important to use the right js/css/fonts folders that come with each version of the library.
 
Upvote 0

MichalK73

Active Member
Licensed User
Longtime User
Ok.

I made a clean environment. New B4J, new JAVA 9, new ABMaterial 4.51 with feedback server, all browsers cleared to zero.
I run DEMO and it does not work (FileManager).
Surprisingly, it works partly on InternetExlorer only !!! But you can not see icons (paste, cut, etc) and folder names. There is no reaction on Chrome or Opera.
Everything works properly on every browser in ABMaterial 4.30 and I see that others have a problem with that.
Well, I had to recompile the client's webapp to version 4.30 until it somehow solves it differently.
I do not know why it works for you?
 
Upvote 0
Top