Another sqlite problem!

giannimaione

Well-Known Member
Licensed User
Hi all,

1) i have Basic4ppcV4-Full :sign0060:
2) i have not a pocket pc:(
3) i am using for my test Standalone Device Emulator 1.0 with Windows Mobile OS Images
4) i am testing sqlite

Now,
program test work fine on desktop compiled, but there is a follow message on ppc compiled when write (insert) data on mydb.sl3 :
some kind of disk i/o error occured.
where do i wrong?
:sign0085: :sign0085:
 

giannimaione

Well-Known Member
Licensed User
Hi Erel,
SQLExample work fine, no error message.
And also sqlcompiled (desktop and device) are not problem!!!!

in my case, the problem is command INSERT INTO .....
in SQLExample there is not INSERTO INTO ..... command

Can you post a your sample sbp with command INSERT ???

Grazie,
Gianni Maione
 

giannimaione

Well-Known Member
Licensed User
no no no...
not work.
i have add code

Cmd.CommandText = "INSERT INTO orders (OrderID, CustomerID) VALUES (98765,'ABCDE')"
Cmd.ExecuteNonQuery

but i have same error:
some kind of disk i/o error occured.

Erel, listen me:
i use Standalone Device Emulator 1.0 with Windows Mobile OS Images,
and i have installed (first time) a demo of software "ORDERS",
and this software have installed:
microsoft sql, net cf 2.0 [it] and another.

After i start to testing sqlite,and i have not sure to follow your instruction about net cf and sqlite.

Now i reinstall all follow your instruction step by step.

I will notice you later.
 

giannimaione

Well-Known Member
Licensed User
Hi Erel,
it is OK!
Problem is "Shared folder" in emulator Properties:
I have set c:\MyFolder as Storage Card,
but SQLITE do not write on it!!!!

see http://www.sqlite.org/c_interface.html
#define SQLITE_IOERR 10 /* Some kind of disk I/O error occurred */
and
SQLITE_IOERR

This value is returned if the operating system informs SQLite that it is unable to perform some disk I/O operation. This could mean that there is no more space left on the disk.
I have moved all files in a another folder of emulator "My Device\Temp" and
now is all ok!!!
Grazie, thanks you
Gianni
 
Top