Bug? B4A Bridge cannot stabilize the connection

rtek1000

Active Member
Licensed User
Longtime User
Hi,

B4A IDE switches between "Connected" and "Trying to connect".

Tried on Windows 10 and Windows 7.

Also on Android 10 and Android 6.

They all stayed the same way.

B4A v11.20

B4A bridge v2.62
 

toby

Active Member
Licensed User
Longtime User
Make sure that there is one and only instance of IDE trying to connect to the same device
 

hatzisn

Well-Known Member
Licensed User
Longtime User

vecino

Well-Known Member
Licensed User
Longtime User
Hello, the same thing happened to me and I found out why.
My router has 2 frequency bands, if you use one of them then the connection to b4abridge is constantly cut off.
If it uses the other band then it works perfectly stable.
I hope this helps.

cual.png
 

rtek1000

Active Member
Licensed User
Longtime User
Hello,

I tried again the b4a bridge, and this instability still occurs.

  • My networks are only 2.4GHz.
  • I tried to change the router,
  • I tried another computer,
  • Tried two computers, two smartphones, and two routers.
  • Tried earlier version of b4a bridge.

But when I tried b4a version 7.30 then the bridged stopped flickering and stayed permanently connected.
 
Last edited:

rtek1000

Active Member
Licensed User
Longtime User
I think I could download the intermediate versions between version 7.30 and 10.6 to know from which version this problem occurs.

I only have these 7.30 then go to 10.6 (which also did not stabilize the connection)

Where can I download old versions of B4A?


(Note: via USB they all work normally)
 

rtek1000

Active Member
Licensed User
Longtime User
I believe it's really a BUG, I managed to reproduce it this way:

  • Uninstall B4A from the computer (I'm using Windows 10 x64, but it also happened with Windows 7 x32).
  • Uninstall B4A Bridge from Android Smartphone
  • Uninstall any other B4A Bridge related App from Android Smartphone such as B4A Designer
Then you can restart, or not, in my tests it was not necessary to restart, neither Windows nor Android.
  • Install B4A Bridge on Android Smartphone
  • Install B4A on Windows
  • Open the B4A Bridge App on Android and click Start
  • Open B4A on Windows
  • Try connecting with B4A Bridge in the Tools menu of B4A on Windows
  • On Android, a question should appear: B4A Designer: Cancel or Install
This question appears with B4A.exe from previous versions of number 10.

After version 10 (or 10.6) this question no longer appears. And the connection to B4A Bridge becomes unstable.

But if B4A Designer is already installed, then the B4A Bridge can maintain a stable connection with B4A.exe even with the higher versions of number 10.

I really don't know why no one has noticed this yet. 😅🤔🥸


Screenshot_20220130-224924.png
 

rtek1000

Active Member
Licensed User
Longtime User
Now I know how to get around this:
  • Open Designer (Designer menu)
  • A window should open (Visual Designer)
  • Click Connect [F2] (WYSUWYG Designer menu)
  • App B4A Designer must be installed on Android (Android must have USB Debugging enabled)

B4A Bridge should be able to reconnect without connection instability.

Thank you for your attention @Erel !
 

rtek1000

Active Member
Licensed User
Longtime User
Nothing has changed in B4A related to the bridge.
The bridge tries to install the designer app when it starts, and after it has the relevant permissions.
It always behaved like this.

As I wrote, there is no bug here. For further discussion please start a new thread in the questions forum.
@Erel, this is the problem, B4A Bridge is unable to install B4A Designer.
 

rtek1000

Active Member
Licensed User
Longtime User
Only with B4A.exe version below 10 can you install B4A Designer using B4A Bridge 🤷‍♂️
 
Top