Android Question B4A missing library

Discussion in 'Android Questions' started by bobmcp, May 11, 2019.

  1. bobmcp

    bobmcp Member Licensed User

    What libraries do I need loaded to run the 'AS MsgBox Android Example'?

    Bob
     
  2. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    If you look at the first post in the related thread -> [B4X] [XUI] AS MsgBox/Dialog, near the bottom there is a "Notes" section that tells you which libraries you need.

    - Colin.
     
  3. bobmcp

    bobmcp Member Licensed User

    OK. Found it. Tnx. But I still can't get it to run. Have 'B4X collections', 'Core', 'Reflections' & 'XUI' libraries loaded & still get syntax errors as indicated in 'errors.png' below.
     

    Attached Files:

  4. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    Have you added the AS MsgBox class to your project?

    - Colin.
     
  5. bobmcp

    bobmcp Member Licensed User

    Nope. I'm simply trying to run the example as posted. I'm interested in using AS MsgBox in a separate app. So, how do I add AS MsgBox class?
     
  6. Computersmith64

    Computersmith64 Well-Known Member Licensed User

  7. Computersmith64

    Computersmith64 Well-Known Member Licensed User

  8. bobmcp

    bobmcp Member Licensed User

    OK. I've downloaded and added the class. But I'm still getting a syntax error. See att

    Bob
     

    Attached Files:

  9. Computersmith64

    Computersmith64 Well-Known Member Licensed User

    The answer is in the thread where you downloaded the example.

    - Colin.
     
  10. bobmcp

    bobmcp Member Licensed User

    The example I was referring to was contained in the file 'ASMsgBox Android Example.zip'. And I've read some of the documentation - thus have added the class as required, but still have an error - see prior post.

    Bob
     
  11. José J. Aguilar

    José J. Aguilar Active Member Licensed User

    As Colin has said, please read the thread

    [B4X] [XUI] AS MsgBox/Dialog
     
  12. bobmcp

    bobmcp Member Licensed User

    OK, thanks all. Finally got it load & run after studying the ASMsgBox.bas file. The problem was missing parameters in the 'InitializeWithoutDesigner' line.

    Bob
     
    Computersmith64 likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice