Android Question B4A v5 and Rapid Debug

Discussion in 'Android Questions' started by Haris Hafeez, Jun 9, 2015.

  1. Haris Hafeez

    Haris Hafeez Active Member Licensed User

    Hi All,

    After updating to B4A, I'm not able to launch an app using Debug(Rapid) mode. The app crashes and doesn't launch and the IDE also shows an error message saying its unable to connect.

    Launching in other modes, Debug(Legacy) and Release works fine. Can someone shed some light and how to resolve this?

    Thanks. 1.jpg 2.jpg
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Can you try it with a real device?
     
  3. Haris Hafeez

    Haris Hafeez Active Member Licensed User

    Yes. It's the same result. An interesting fact here is that the Bridge does install the app and tries to launch it as well but the app launch fails because the IDE throws up the error message shown above.

    I'm using JDK 1.6.0_45(I know its old) and Android v22 jar.
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    It is better to install and use a new version of Java (7 or 8). You can keep the old version as well if you like.

    Does it also happen with a new empty project?
     
  5. Haris Hafeez

    Haris Hafeez Active Member Licensed User

    I am going to test this on my home machine and see if its a Java related issue.
    And yes, it does happen with an empty, new project as well.
     
  6. Haris Hafeez

    Haris Hafeez Active Member Licensed User

    This only appears to be a problem with my work machine where I've got JDK1.6.x set up. The home machine has JDK1.7 and works fine with Debug(Rapid).
     
Loading...