iOS Question B4i Builder loses wifi connection.

Discussion in 'iOS Questions' started by touchsquid, Apr 15, 2015.

  1. touchsquid

    touchsquid Active Member Licensed User

    I am using an iPhone 4 with IOS 7 as a test device. Connecting via B4I - bridge works the first time, for a minute or so then it drops the connection and the "waiting for IDE to connect" comes up and it nver connects again. The only way to get it reconnected is to reboot the phone. I have tried all sorts of router settings, rebooted the router several times, but the same thing happens every time I use B4i - bridge. After the failure all other apps, email, browser etc all lose wifi connectivity too, although settings shows it connected to my network and a strong signal. I am within 2 meters from the router.

    If I reboot the phone, and do NOT use B4i bridge, the phone works fine, so I am pretty sure it is the B4i bridge messing up the connection.

    Any ideas appreciated. UIcloud works, so I am pretty sure everything is configured correctly.
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    I haven't encountered this issue with any of the test devices (including an iPhone 4s). With that said, in the UI Cloud there is an iPhone 4s and there are connection problems with this device, though tt doesn't require a boot to reconnect.

    Are you using the hosted builder? If yes try to build a new bridge app. The latest version might work better.
     
  3. touchsquid

    touchsquid Active Member Licensed User

    Thank you Erel,

    I am using the hosted builder. I will try a new bridge app, but I only started using B4i a few days ago so mine is quite new.

    I took the phone home and tried a different computer and router, and it works perfectly there, so I am guessing router settings can affect it, although I don't know what setting it might be. I suspect a connection timeout. Odd that the iphone wifi stops completely. I am using static IP.
     
  4. touchsquid

    touchsquid Active Member Licensed User

    I tried a different router at the office, and it is now working more reliably. It still loses the connection sometimes, but reconnects OK. Since the offending router is fine for everything else, it probably is a router settings issue.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice