iOS Question b4i unable to install "b4i-bridge" please try again later

Status
Not open for further replies.

davemorris

Active Member
Licensed User
Hi ~Guys
Just got may hands on a Apple 6S phone and tied to install the bridge (prevously I have been using a old iPhone 5S)
But are having problems with installing the bridge.

I have followed the steps in Erel's Certificate and provisioning profile - I was very careful and sure I got it right (but it is the first time I have setup a new phone - the previous phone 5S was setup by a colleague).

Anyway, when I try to install the bridge I get a Grey icon the phone and when I click on the icon it shows the message:

Unable to install
"b4i-bridge"
please try again later

I am running B4i 6.3 and there is a thread https://www.b4x.com/android/forum/threads/b4i-bridge-doesnt-install-on-iphone-11.110182/
but, although it shows the same message, I don't think it applies to my problem (sorry if I missed something).

Sure it is something simple I am doing wrong, can anyone help?

Kind regards
Dave
 

davemorris

Active Member
Licensed User
Hi
Just an update: I tried switching back to my old 5S device and used a previous project (which did work) and when I tried to compile I got the following error message.
------------------------
B4i Version: 6.30
Parsing code. (0.16s)
Building folders structure. (0.36s)
Compiling code. (3.43s)
Compiling layouts code. (0.10s)
Compiling debugger engine code. (4.96s)
Building Xcode project (0.37s)
Sending data to remote compiler. Error
Out: Build settings from command line:
ARCHS = arm64
CODE_SIGN_IDENTITY = iPhone Distribution: Momentum Ltd (WNLQ68N9D9)
CONFIGURATION_BUILD_DIR = /Users/administrator/Documents/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PRODUCT_NAME = SuperOrder
PROVISIONING_PROFILE = cc60ad33-6f7c-4dae-af70-d90956830bc6

note: Using new build system
note: Planning build
note: Constructing build description
Build system information
error: Provisioning profile "SuperorderAdHoc" doesn't include signing certificate "iPhone Distribution: Momentum Ltd (WNLQ68N9D9)". (in target 'B4iProject')

Build system information
warning: unexpected C compiler invocation with specified output: '/Users/administrator/Documents/UploadedProjects/<user id>/Payload/SuperOrder.app/main.m' (for input: '/Users/administrator/Documents/UploadedProjects/<user id>/main.m') (in target 'B4iProject')
B4i Version: 6.30
Parsing code. (0.16s)
Building folders structure. (0.36s)
Compiling code. (3.43s)
Compiling layouts code. (0.10s)
Compiling debugger engine code. (4.96s)
Building Xcode project (0.37s)
Sending data to remote compiler. Error
Out: Build settings from command line:
ARCHS = arm64
CODE_SIGN_IDENTITY = iPhone Distribution: Momentum Ltd (WNLQ68N9D9)
CONFIGURATION_BUILD_DIR = /Users/administrator/Documents/UploadedProjects/<user id>/Payload
OTHER_CODE_SIGN_FLAGS = --keychain <user id>
PRODUCT_NAME = SuperOrder
PROVISIONING_PROFILE = cc60ad33-6f7c-4dae-af70-d90956830bc6

note: Using new build system
note: Planning build
note: Constructing build description
Build system information
error: Provisioning profile "SuperorderAdHoc" doesn't include signing certificate "iPhone Distribution: Momentum Ltd (WNLQ68N9D9)". (in target 'B4iProject')

Build system information
warning: unexpected C compiler invocation with specified output: '/Users/administrator/Documents/UploadedProjects/<user id>/Payload/SuperOrder.app/main.m' (for input: '/Users/administrator/Documents/UploadedProjects/<user id>/main.m') (in target 'B4iProject')


Error: ** BUILD FAILED **
----------------------

I went back to my "Apple development account", and in the list of Certificates I noticed two entries with the same name, and type:

Momentum Ltd iOS distribution but one expires on 2020/7/16 and the other 2021/01/16

Could this be the problem?

Kind regards
Dave

I

Error: ** BUILD FAILED **
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
have you registred your iPhone 6S on your Apple developr account?

if yes then try to create all the cerificates..
I remember that when I deleted b4iBridge by mistake, to resintall it I started from the begin again:
(including creating new certificates..etc..)
 
Upvote 0

davemorris

Active Member
Licensed User
Hi, Thanks for the response

1. yes the iPhone is registered with Apple developer and it appears in the devices list.

Concerning the Bridge - I uninstalled the bridge on my older phone (iPhone 5S running iOS12 ) and re-install it. - without problems.

However, if I attempt to install the bridge on 6S iPhone running iOS 13 it still gives the message.

Unable to install
"b4i-bridge"
please try again later

Incidentally, the compiler error in my second post appears to have gone away - I tried to compile a debug and release version previous working project for the 5S phone and it works ok (so I am not sure what went wrong there).

I just wonder if I should (do as the message states) leave it and retry tomorrow.

Kind regards
Dave
 
Upvote 0

davemorris

Active Member
Licensed User
Hi, Me again

Just an update, tried again today - same problem the Bridge icon was grayed out.

I look forward to a suggestion, this is stopping me move forward with the 6S phone (however, the 5S works ok).

Kind regards
Dave
 
Upvote 0

aeric

Expert
Licensed User
There are 2 settings in your iPhone that need to check in "General".
1) Tap on "About", scroll to bottom and tap on "Certificate Trust Settings". Turn on the "ENABLE FULL TRUST FOR ROOT CERTIFICATES"
2) Tap on "Profile", make sure you see the "B4I" certificate is installed and verified.
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
after checking the idea of Aeric,

create a new basic b4i App just to install b4i bridge in your iphone6;

create new certificates/mobile prof etc;

also note:
because the error said something with sign..
it is why I thunk you should create all the cerificates and try to install b4i-bridge, and try to install a basic B4i App first.
 
Upvote 0

davemorris

Active Member
Licensed User
Hi Aeric

I have looked at the settings on the two phones, please remember one is a 5S running iOS12.4.4 and the problem phone is a 6S running iOS13.3 and the settings options are slightly different.

The working phone 5S is as you described in your post, however the "Enable full trust for root certificates" for B4i is OFF but it still works.
Also, under General->profile the B4i is show.

However, for the problem 6S phone there is nothing about "Enable full trust for root certificates" and B4i is not shown. Also, the General->profile is simply missing (unless I am looking in the wrong place) is shows VPN (not enabled) then Legal &Regulatory. The good 5S shows VPN (not enabled), Profile (B4i) and then Regulatory.

I was also under the impression that for the Hosted builder it was not necessary to "Enable full trust for root certificates" as for the 5S.

Thanks for the help, I hope my response is clear.

Regards
Dave

P.S. Also the 6S phone appears to work ok - I have installed and run the other apps I have written, however with the Bridge I am unable to run it in debug mode.
 
Upvote 0

aeric

Expert
Licensed User
Sorry, my iPhone 7 Plus still running on iOS 13.1.2 and not updated to 13.3
 
Upvote 0

davemorris

Active Member
Licensed User
Hi, Erel, Aeric and AOrester0 - thanks for the quick response - but I am still having problems let me recap.

The problem, when I tried to install the "b4i - bridge" the icon is grayed and I get the following message when I click in it.
__________________
Unable to install
"b4i-bridge"
please try again later
_________________

What I have done so far (and please disregard my second post about the compiler error as that problem has simply gone away)
1. I am fully registered with Apple as a developer and have previously debugged, release and published Apps without problems.
2. I started by Issuing a new certificate and provisioning profile - which included the Udid for the new 6S device (I am sure that is correct).
3. I checked the whole process with my old 5S phone - and it works OK (which, to me, suggests most of certification process is OK).
4. I have fully installed the trust certificates no my phone see an old post (thanks to Aeric for the pointer)
5. I have rechecked the Udid and Package has the device ticked.
6. Checked the 6S phone works with other applications I have already released to Apple.

In response to Erel's questions
1. You are using a different certificate or provision profile in debug mode. This is not needed.
I am attempting to install the bridge - I don't understand how the question is relevant?

2. The CPU type (32 bit - 64 bit) setting is wrong under Tools - Build Server - Settings.
I have checked the setting, and it is 64Bit - the phones are 5S and 6S - I believe that is correct.

Thanks again for the help so far, but it I tried again and it still does not work.

Kind regards
Dave
 
Upvote 0

davemorris

Active Member
Licensed User
Hi, Erel thanks for the help, but unfortunately it still don't work.

On both phones I uninstalled the bridge before starting, and the compiler does not report any problem.

1. Did a forced restart on the 6S phone - by holding both the power and home button in together (as advised on the internet) - previously I just switched the phone off and then restarted it (I am not an Apple man but I assume it is the same thing).

2. Started new project as requested - Tied to install the bridge on the 6S phone (running iOS 13.3) and it failed again as above.

3 For the 5S phone(running iOS 12.4.4) tried installing the Bridge - and it works.

Just an additional note, when I tried to uninstall Bridge on the 6S phone (the grayed icon) instead of the normal stuff It says "Cancel Download", so along with the "please try later" when you click on the grayed icon, it would appear there is some type of holdup. Also, I did try leaving the phone on for a few hours to see if that would clear the holdup - it did not.

I wonder if it is the phone itself (I am not an Apple man but otherwise it appears to work great) - Just wish I had another 6S to try.

Kind regards
Dave
 
Upvote 0

davemorris

Active Member
Licensed User
Hi, still not working.

It tried to changed the package name to example3 (but still using the same keys folder) , and still the same gray icon appears.

Note: Not sure it will help but the keys folder I am using contains other provisioning files (to support notifications etc) for other projects including the one generated for the B4i-bridge called "provision.mobileprovision".

Also, (just in case it is a 6S - iOS13.3 issue) perhaps if any one else could try re-installing the Bridge on a 6S, it could help eliminate my Phone.

Kind regards
Dave
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
I don't know.. like I said before it looks to me you really should start from the begin..
a new App demo very basic own package, new key, new certificates etc..

yes.. maybe also it is just a problem with that iPhone6, (i don't have any to test)
 
Last edited:
Upvote 0

davemorris

Active Member
Licensed User
Hi, thanks for checking the bridge installs on a 6S.

I did doubled check the UDID and it is correct (looks valid) - I am sure Apple would reject a bad UDID (if they don't, they should).
I will try again from scratch as suggested - I will even try with an new key folder.

1. Just a question before I do, these are several provisioning files in the old key folder for previous projects (all working great) - is it OK to switch to the new key folder then back the old or will it affect something (apart from trying to use the 6S phone with that project).

2. Also, I am sure Apple only allow a maximum of 6 certificates, I already have 6, including two certifications with the same name (the early one was used by the previous projects) - is it OK revoke LATER one (which is used by the original attempts at installing the Bridge).

Kind regards
Dave
 
Upvote 0

f0raster0

Well-Known Member
Licensed User
now or later you will need to update your certiciates, then delete all the certificates will not a problem
(...Momentum Ltd iOS distribution but one expires on 2020/7/16 and the other 2021/01/16")

1) yes Ok if you keep the old key/certificates etc.
2) yes ok, just keep the minimum, only the ines that you need.

Question:
The basic b4i App to try to install b4i-bridge,
Do you write the certificate name and mobilepro into the code? because it way you can switch certificates/mobilepro..

Follow this:
1) create a new App
2) create a signkey (apple: you can delete it and create new, android you have to keep the same)
3) create new certificates/mobileprovision
4) into the code of you new very basic B4i App writr the name of the new certificate and mobileprovision (it is very important when into your folder you have 1+ certificates/mobileprovision)

But to me, you should delete all key/certificates/mobileprovision on Apple and from your folder. (when I deleted b4i-bridge by mistake, the only way to reinstall it again was when i deleted all, and started from scratch)
 
Last edited:
Upvote 0
Status
Not open for further replies.
Top