B4J Question b4j ide running slow

tufanv

Expert
Licensed User
Longtime User
Hello,

After adding some lines of codes my b4j is starting to run slow, typing code comes laggy and everything works slower on the ide although I have a high end computer. What may be the problem ? I saw some ini config changes in the search for "b4j slow" but they did not work out.

Thanks
 

delgadol

Member
if you have many jvm process running, if possible that your app run very very slow, others case is if your new code need many resources , example manage big file size or proccess a api with remote server in over load (long time resquest )
 
Upvote 0

tufanv

Expert
Licensed User
Longtime User
Does it only happen with B4J? Are there many red errors in the code?
I didnt check b4a or b4i but there are no so much errors. Also it is very slow that I end up tryping the code and code comes laggy and when when it finally ends typing them on the screen, it takes 5-6 econds for b4j to understand that there is no problem at the code ( it goes from red to black after 5-6 seconds )
 
Upvote 0

tufanv

Expert
Licensed User
Longtime User
if you have many jvm process running, if possible that your app run very very slow, others case is if your new code need many resources , example manage big file size or proccess a api with remote server in over load (long time resquest )
I don't have.
 
Upvote 0

tufanv

Expert
Licensed User
Longtime User
Yes, no luck. This evening I will post a video from the ide, you can understand better. I am using 2 monitors but I dont think that may be related.
 
Upvote 0

tufanv

Expert
Licensed User
Longtime User
A video will not help.

Start a new project. If it is slow then there is a local problem. Maybe anti virus is doing something.
It is not related to the two monitors.
At first there are no problems it starts after having aroun 300-400 lines of code
 
Upvote 0

tufanv

Expert
Licensed User
Longtime User
Deleted the ini, still slow but not as yesterdays Also I dont have virus or malware in my computer but I also checked it with Kaspersky, ( I have it on pc enabled ) no sign of anything. Also b4i and b4a doesnt have this behaviour, on my laptop everything is normal.
 
Upvote 0

John Naylor

Active Member
Licensed User
Longtime User
I had similar with large b4j apps (which didn't happen in B4A) and solved it in an unlikely way which may or may not be relevant in your case.

Every now and then b4j 'froze' for a second or two but if I was still typing the characters would appear when b4j unfroze.

The solution for me? I changed the batteries in my wireless keyboard and mouse. I could only put it down to some strange interaction between my keyboard or mouse driver and the Java processes running in the background.

I appreciate the chance of this being your issue is very slim but this worked for me so I would be remiss if I didn't offer it up!
 
Upvote 0

MichalK73

Active Member
Licensed User
Every now and then b4j 'froze' for a second or two but if I was still typing the characters would appear when b4j unfroze.
I have the same thing on a laptop, not on a PC.
I need to test what you say with the battery in the mouse, just take the mouse on the USB cable. I will check your theory at home.
 
Upvote 0

Harris

Expert
Licensed User
Longtime User
Mine does this when the auto-backup is running.
The whole IDE will freeze (can't scroll page, type chars, etc) until the backup completes. You can see this on the status bar when the backup file (zip) is completed successfully.
This is my B4A ide, where auto-backup is ON. I have it turned off in B4J at the moment...
 
Upvote 0

Harris

Expert
Licensed User
Longtime User
You're right. Freezing B4J is associated with autobackup and not with a wired mouse.
and larger projects... whatever large implies... (mine is currently 15 MB).
Maybe a button and reminder to backup, rather than scheduled every 10 mins...
 
Upvote 0
Top