Android Question Bal File Not Found B4A 8.80

Discussion in 'Android Questions' started by Phil Thompson, Jan 1, 2019.

  1. Phil Thompson

    Phil Thompson Member Licensed User

    I just updated to B4A 8.80... Previous version worked fine.
    The bal cannot be found.
    Files/tablet.bal exists

    code Line 207
    LayoutVal =Activity.LoadLayout("tablet")

    error in debug mode
    main_activity_create (java line: 508)
    java.io.FileNotFoundException: files/tablet.bal

    Both Debug and Release mode fail to load the bal file
    I even tryed renaming Files/ to files/ with no effect

    Any suggestions????
     
  2. Shelby

    Shelby Active Member Licensed User

    I think it worked for me that when in the API I entered into the Files manager window on the right side window of the split screen.
    At the bottom there is a button (Add Files) which can be clicked. Then it will allow you to navigate into your computer until you find the specific .bal file if you still have it in your B4A files somewhere (apparently in your case it's tablet.bal). Select it and it will appear in the Files Manager screen. If you see the file already in the Files Manager window you might try removing it with the Remove button; then use the Add Files button.
    P.S. If you don't see the Files Manager it can be accessed within the windows tab.
     
    Last edited: Jan 1, 2019
  3. Phil Thompson

    Phil Thompson Member Licensed User

    Thanks for the reply
    Been there Done That
    The file appears in the Files\ directory
    The file appears in the files tab as described above
    the file loads into the designer just fine

    The file will not transfer to the android device.
    Th file missing error is triggered in the log when I attempt to run the application
     
  4. Shelby

    Shelby Active Member Licensed User

    I think some of the more knowledgeable members here will suggest that you post some of your related code. I'd suggest lines 504 through 511 since you showed that the error message points to line 508.
     
  5. Cableguy

    Cableguy Expert Licensed User

    I would recommend to delete the project .Files that are created by the IDE upon creation of the B4A file, like the meta file.
    I think there's 2 or 3 files..
    Then reload the project so that the IDE recreates those files! (Assuming you already did a "clean project")
     
  6. jimmyF

    jimmyF Active Member Licensed User

    Did you click on Sync in the File Tab?
     
    BillMeyer likes this.
  7. tomib

    tomib New Member Licensed User

    I had the same problem. You have to completely remove application from device (phone, tablet) and start it again with release or debug mode.
     
  8. viriato

    viriato Member Licensed User

    Hello,
    I still have the same issue , I removed the application from phone and deleted the .meta file and re-installed everything
    If I use debug mode I still have the error in the LOG " java.io.FileNotFoundException: main.bal " , but the application works on the phone
    if I use "release" mode the application crash at the beginning with same error ..

    Thanks for your suggestions
     
  9. Erel

    Erel Administrator Staff Member Licensed User

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice