Android Question Blank Sqlite database

Discussion in 'Android Questions' started by fasilosman, Jun 8, 2015.

  1. fasilosman

    fasilosman Active Member Licensed User

    Hi all

    I am using adb pull and adb push to transfer SQLite database from PC to Android device via cable.

    The problem is when I copy from device to PC, if I open the SQLite database with SQLite database browser it is blank with the size of 800KB. But there are table and records when I am using the android app.

    Please help me in this regard.

    Thank you
  2. ivan.tellez

    ivan.tellez Active Member Licensed User

    Maybe its not the same database file. Check the paths.
  3. fasilosman

    fasilosman Active Member Licensed User

    It is the same file path that I am using for ADB Push. I also tried coping manually by copy and paste. But not working
  4. Erel

    Erel Administrator Staff Member Licensed User

    Is the file actually blank (all 0 bytes) ?
  5. fasilosman

    fasilosman Active Member Licensed User

    Thanks all.
    The file was actually blank.

    I found the reason. The file was in the system directory.

    I change to different path or SDcard it worked.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice