bug with media player?


Well-Known Member
Licensed User
Longtime User
OK so I am seem to have a strange issue.
I've read on the forums that it is not wise to exitapplication to close an app.

However I have noticed a 'bug'.

If I do not specifically use exitapplication in Activity_Pause
and then go to open another one of my apps developed with b4a they crash.

They all get the same error:
java.io.IOException: Prepare failed.: status=0x1

It does not matter which app. It's all the same error and only affects my apps from b4a. The line number in all instances points to a line where I am attempting to load a sound file (example):

mdpBleep.Load(File.DirAssets, "Bleep.wav")

When I go back to my app
(Ultimate Crossword in this case) and put the command exitapplication in Activity_Pause this behavior dissapears.

Furthermore I can't seem to duplicate this behavior on my other devices. Only my Samsung Infuse.

I thought it was specific to some issue with my device but then
walterf25 showed the same error when testing one of my apps:


Has anybody come accros this issue?


Well-Known Member
Licensed User
Longtime User
Thank you Erel. I will try that when I get home. I figured it would be something as simple as that.