Android Question C:\Program Files (x86)\Anywhere Software\Basic4android\libraries\android-support-v4.jar

Status
Not open for further replies.

rkmoray

Active Member
Licensed User
Many times, as I am looking at new libraries, MSIconicDrawableDemo for example.I get an error message "C:\Program Files (x86)\Anywhere Software\Basic4android\libraries\android-support-v4.jar". I don't even code anything for it, just add it to my libraries. Why do I get this error, and more
importantly, what can I do to solve it?
 

DonManfred

Expert
Licensed User
Please edit the thread-title to be more useful!

If you are using B4A 6 then i guess you need to change the DependsOn line in the Library´s XML file

Try to replace "android-support-v4" with "com.android.support:support-v4" in the dependson-line in the library.
 

rkmoray

Active Member
Licensed User
Thank y for the reply. I thought my title was very specific.
I am using B4A 6.0,
I will try your solution.
 

stanmiller

Active Member
Licensed User
Try to replace "android-support-v4" with "com.android.support:support-v4" in the dependson-line in the library.
This worked for me too.

I changed the <dependsOn> line in the StdActionBar library XML and now the build pulls the library from the Android SDK. Cheers.

 
Last edited:

Enrique Romo

New Member
Licensed User
Works fine. Thanks a lot!
You can also include this code statement under #Region Activity Attributes and it works the same:
#AdditionalJar: com.android.support:support-v4

1595870990575.png
 
Status
Not open for further replies.
Top