Android Question Can download to phone but not AVD

Discussion in 'Android Questions' started by Jeff Garland, Jun 20, 2015.

  1. Jeff Garland

    Jeff Garland New Member Licensed User

    I just upgraded B4A from 4.3 to 5.0. Everything works fine except I can't compile and download to any AVDs. I can create AVDs. At first they ran just fine and seemed to work normally except I could not download new compiles to them.

    I could and still can compile and download to my phones and tablets just fine. When I tried to compile and download to AVDs it timed out even if I set the timeout way out there.

    i didn't change anything and now when try to run an AVD it comes up to the emulator screen and the "Android" shiny startup screen just sits there with the reflection effect working but nothing else. It never boots on into the phone or tablet emulator.

    No Errors now at all.

    Any ideas?

    Thanks
    Jeff
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Try to delete the AVD instance and create a new one.

    I recommend you to avoid using the emulator at all. Use a real device or a VM such as genymotion.
     
  3. Jeff Garland

    Jeff Garland New Member Licensed User

    HI Erel

    I deleted and recreated multiple times and I still get the same.

    I do use real phones and tablets most of the time but the emulator is good when I need to test a resolution that I don't have an actual device for. It always worked well in the earlier versions I had installed.

    I'm OK. Thanks

    Jeff
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    Note that the error you see has nothing to do with B4A. The emulator (which is part of Android SDK) refuses to start for some reason.
     
Loading...