Cannot start B4PP anymore on desktop: "A problem was encountered"

Discussion in 'Questions (Windows Mobile)' started by Frank, Nov 11, 2008.

  1. Frank

    Frank Member Licensed User

    Hi there,
    I have used B4PPC for over a year now with no problems.
    In the last weeks I didn't use it (too much other stuff), but when I wanted to start it yesterday on my PC, it didn't even start up. Instead I got an error message "Basic4PPC encountered a problem and must be terminated" (or similar; freely translated from my German message).

    I use Windows XP and B4PP V6.50. Un- and reinstalling B4PPC didn't help.

    B4PPC programs that I compiled for PC still run on the PC, so I don't think it's a problem with the .Net-version.

    I somehow fear that it might be related to Microsoft Visual Studio 2008, which I installed recently - I just cannot remember if I used B4PP on the desktop after the installation or not.

    Does anyone have an idea what might be going wrong here? How can I check which files/dlls/resources I need when starting up B4PPC?

    Thanks for any help.

    Frank
     
    Last edited: Nov 11, 2008
  2. klaus

    klaus Expert Licensed User

    Have you copied the license.txt file into the program's folder ?

    Grüsse.
     
  3. Frank

    Frank Member Licensed User

    Re: license.txt

    Well, there is a file license.txt in the same folder where also the Dbasic.exe is.
    I haven't explicitly copied it there, as I installed B4PPC once (I think it was Version 5.30) and upgraded ever since... - but it's there.
     
  4. agraham

    agraham Expert Licensed User

    The next thing I would try is to save the license.txt file, uninstall Basic4ppc then delete the Anywhere software folder in Program Files then reinstall and copy back licence.txt. That way you have a totally clean installation.
     
  5. Mr_Gee

    Mr_Gee Active Member Licensed User

    Strangely enough I had the same issue last sunday on my laptop,
    I removed the application (through windows remove programs)
    next I deleted the program directory
    dowloaded the application, and reinstalled it again

    It gave me an error "licence.txt not found" so I copy pasted the file in the
    B4PPC directory and it worked..

    Hopefully it will work for you too ..

    ps. I don't have MSVis.Studio installed on this PC, but i did have it on another PC for a while and B4PPC did play nice with other applications
    SharpDevelop/Vis.Studio etc.
     
    Last edited: Nov 11, 2008
  6. Frank

    Frank Member Licensed User

    It worked!

    It worked! Uninstalled B4PPC from Windows Control Panel, reinstalled and copied licence file back - and now it runs again.

    Thanks for your help,

    Frank
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice