iOS Question Can't Compile app with 6.00 BETA #1

aaronk

Well-Known Member
Licensed User
Hi,

I have updated the B4i IDE to the new beta (6.00 BETA #1) and I found it failed to compile my app.

Everything was working fine before I updated the IDE.

I then thought the Certificate / provision profile had an issue, so on the Apple Developer Console I deleted the files are started again. However still go the issue.

When I compile my app (in debug) it shows the error as attached.

Any ideas on what I have missed or done wrong ?

I followed the video from the following link: https://www.b4x.com/android/forum/threads/creating-a-certificate-and-provisioning-profile.45880/

Error attached as it was too big to post.
 

Attachments

aaronk

Well-Known Member
Licensed User
Still got the same result after updating the Firebase framework. (same error).

I even created a brand new project and added no code to it (just default code) and same result when compliing.
 

aaronk

Well-Known Member
Licensed User
I forgot about the large zip file I had to download. I just downloaded that file and copied the files.

It now has that file, but still doesn't let me compile.

See attached. This is the new error it shows.
 

Attachments

aaronk

Well-Known Member
Licensed User
Got it to work.

Needed to reboot the Mac.

Looks like the Mac did a update and updated to Xcode 10.3. It kept coming up saying it needed to do a reboot but I kept ignoring it as I was busy and didn't want to reboot the computer (like most people).

Did a reboot and now it seem to allow me to compile the app with the beta.
 
Top