Android Question Can't compile v9.00

Scantech

Well-Known Member
Licensed User
Why i can't compile this anymore?

B4A Version: 9.00
Parsing code. (0.39s)
Building folders structure. (0.02s)
Compiling code. (0.49s)
Compiling layouts code. (0.04s)
Organizing libraries. (0.00s)
Generating R file. (0.00s)
Compiling generated Java code. (0.20s)
Convert byte code - optimized dex. Error
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$anim;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$attr;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$bool;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$color;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$dimen;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$drawable;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$id;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lnet/steamcrafted/materialiconlib/R$integer;
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
at com.android.dx.command.dexer.Main.processAllFiles(Main.java:696)
at com.android.dx.command.dexer.Main.runMultiDex(Main.java:370)
at com.android.dx.command.dexer.Main.runDx(Main.java:291)
at com.android.dx.command.dexer.Main.main(Main.java:249)
at com.android.dx.command.Main.main(Main.java:94)
Caused by: java.lang.InterruptedException: Too many errors
at com.android.dx.command.dexer.Main.processAllFiles(Main.java:688)
... 4 more
 

Scantech

Well-Known Member
Licensed User
I had to do a clean project on my customlistview for new material icon 2.0 to work. Now its ok. I think it had something left over with materialicon 1.5 which is not forward compatible.
 
Top