Android Question Compile and run from NAS server

Discussion in 'Android Questions' started by TrisectDevelopment, Dec 4, 2013.

  1. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    I have just purchased a NAS Server from Western Digital. Its a WD MyBook Live.

    So I copied all my source code to the NAS Server and I can open them from B4A. I can compile and add new files(layouts) from B4A.
    But when I try to run it I get an error.
    "Unfortunately 'APP' has stopped."

    If I moved my project to my desktop it runs okay.

    Anyone know what could be the problem.
    I would like to use my NAS Server as a Development drive. Thats the hole point.
     
  2. NJDude

    NJDude Expert Licensed User

    What the unfiltered logs says?
     
  3. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    Something like this maybe:
     
  4. NJDude

    NJDude Expert Licensed User

    Are you running the app in DEBUG mode?
     
  5. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

  6. NJDude

    NJDude Expert Licensed User

    Then is the debugger being unable to find the device.
     
  7. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    Try to run it from NAS in release:
     
  8. NJDude

    NJDude Expert Licensed User

    I see, the APK apparently is not being created on your NAS
     
  9. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    I deleted the APK file on the NAS and compilede Again (under Release) and this time it compiled without error, but when trying to run it give me the old error again.
     
  10. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    The APK file is created on the NAS server. When running the App.
     
  11. Erel

    Erel Administrator Staff Member Licensed User

    You should check the logs when you see the "Unfortunately App has stopped" message. There must be an error message there.
     
  12. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    When I get back to my offfice I'l see if I can copy the logs and display them here.
     
  13. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    Heres the logs when trying the emulator:



     
  14. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    When running my App from my desktop it says "Waiting for debugger to connect". I don't see that when running from NAS.
     
  15. Erel

    Erel Administrator Staff Member Licensed User

    The emulator may be broken. Try it with a real device.
     
  16. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    Its the same with a real device.
    The App gets installed.
    I then click Open on the device and after some time I get the "Unfortunately" error.

    This is the log:
    I tried to change the right of the APK file on my NAS server, but that did not help.

    I think that it maybe something to do with rights because it runs fine if I run the same project from my local harddrive.
     
  17. Erel

    Erel Administrator Staff Member Licensed User

    This is a different error.
    You should first add the TabHost to its parent.
     
  18. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    This is my code.
    This code Works if I run it from my harddisk.
     
  19. Erel

    Erel Administrator Staff Member Licensed User

    The compiler needs to write several files during compilation. Seems like the files are not written correctly with the network storage.
     
  20. TrisectDevelopment

    TrisectDevelopment Active Member Licensed User

    What are those files?
    Maybe I can se if I can find them and see if they get created.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice