Android Question Compiling Resources Error



I have a difficult problem, and it seems that I can not solve it. I already have tried really a lot. Since days.

I got this log:

B4A Version: 11.00
Parsing code. (0.00s)
Java Version: 11
Building folders structure. (0.01s)
Compiling code. (0.00s)
Compiling layouts code. (0.00s)
Organizing libraries. (0.00s)
(AndroidX SDK)
Compiling resources Error

The interesting thing is that this is also appearing if I use other small example programs. So it is not my code causing this problem.
It stops exactly in this line without any further message.

Any idea?

Windows 7.
I have installed the latest b4a, with the resources and configured the pathes as shown on the main page of b4a. Also Android 30.

Thanks in advance.

PS.: I have also a b4a version of 2015 on my computer, but of course with complete other pathes for all the resources. So this is not the problem. And that version is still working fine. But of course outdated.



Hello, yes, here it is.

I have placed the cursor to the end of the line to show you the java and android files.

I will install B4A now on a notebook.
Upvote 0


Thank you.
I have downloaded all the files again and was using 7zip instead of winrar now.
But I got the same error message.

And one further strange thing: I installed it also on a notebook and the same error appears.
Again Windows 7. SP1 Home Premium.

I was following all the steps.
Upvote 0


Hello again, the problem is solved. At the moment for one computer. It was really the AAPT2 tool.

What I did now: I deleted all the files in the android folder (SDK and resources).
I have also deleted the files I have downloaded with the sdk manager!!!
First time I didn't delete it.
Then I got an error message and it stops again on the same position as before (during compiling).
But before it stops without any message.

Missing DLL - AATP2 Error. Downloaded the Visual C++ Redistributable for Visual Studio 2015 (I thought I have this already)
Now it works!

Thanks for the time.
Upvote 0