Android Question Custom B4XLib Library issue

Jakes72

Active Member
Licensed User
Longtime User
Hi Experts,

I have created a custom library of type 'B4XLib'. Now I have made the manifest.txt file and put it together with the .bas file and then zipped it to form the library. The problem is that my manifest.text file contains this:
Version=1.00
B4J.DependsOn=JdbcSQL
B4A.DependsOn=JdbcSQL
B4i.DependsOn=JdbcSQL

But it is not automatically bringing in the JdbcSQL dependancy library in my project for my custom library and I still have to add it manually.
I know this because I get an error message and when I add it manually the error goes away. What am I doing wrong any ideas?

Many thanks.
 

Jakes72

Active Member
Licensed User
Longtime User
Hi Erel,

Here is the uploaded library as you requested.
 

Attachments

  • JdbcSQL.zip
    13.6 KB · Views: 73
Upvote 0

Jakes72

Active Member
Licensed User
Longtime User
Erel I have uploaded a screenshot of the error here:
 

Attachments

  • Image1.jpg
    Image1.jpg
    185.6 KB · Views: 149
Upvote 0

Jakes72

Active Member
Licensed User
Longtime User
I also changed manifest.txt file to this:

Version=1.00
B4A.DependsOn=JdbcSQL


But still get error.
 
Upvote 0
Top