Android Question Debugger Not Working

Discussion in 'Android Questions' started by Mike1970, May 12, 2019.

  1. Mike1970

    Mike1970 Active Member Licensed User

    Hi, i'm using B4A Bridge, and i can't see the log messages..
    I enabled the Debug USB option in my phone, and i enabled the developer-mode

    • I also tried via USB but it give me this and nothing else:

    Logger connected to: 710HVBR423CFB
    --------- beginning of system
    --------- beginning of crash
    --------- beginning of main


    • Via B4A Bridge give me this:

    Logger connected to: meizu M5c
    --------- beginning of main
    getServiceInstance failed!
    PerfServiceNative_notifyRenderTime init fail!
    getSlotFromBufferLocked: unknown buffer: 0x7fc8105e90
    getServiceInstance failed!
    PerfServiceNative_notifyRenderTime init fail!
    getSlotFromBufferLocked: unknown buffer: 0x7fc80faaf0
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Logs are probably disabled on your device. Are you able to see the logs in release mode with #BridgeLogger set to True?
     
  3. Mike1970

    Mike1970 Active Member Licensed User

    Yes, i wrote it, but nothing
     
  4. Jorge M A

    Jorge M A Active Member Licensed User

    This work for me:
    a) Unplug the device
    b) Revoke USB debugging authorizations. (Settings > System > Developer Options > Debugging)
    c) Retry.​
     
  5. Mike1970

    Mike1970 Active Member Licensed User

    I solved (i don't know how)...
    - Disabled "Verify app via USB"
    - Enabled "Enable detailed logging"
    - Set 4MB to "Buffer Logger Size"
     
    Erel and Jorge M A like this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice