iOS Question Disable Webview's scroll bar?

susu

Well-Known Member
Licensed User
In B4A, I can use WebViewXtender to disable the scroll bar. How can I do this in B4i?
 

susu

Well-Known Member
Licensed User
Thanks!

I set the background to transparent but why it still White?
 

susu

Well-Known Member
Licensed User
Try this:
B4X:
Dim no As NativeObject = WebView1
no.GetField("scrollView").SetField("scrollEnabled", False)
I was wrong. I want to hide scroll bar of webview not disable scroll. Something like this:
webView.scrollView.showsHorizontalScrollIndicator = NO;
webView.scrollView.showsVerticalScrollIndicator = NO;

I tried:
no.GetField("scrollView").SetField("showsHorizontalScrollIndicator", "NO")
but it doesn't work.
 

susu

Well-Known Member
Licensed User
It still doesn't work:
[<_UIWebViewScrollView 0x16eb7190> setValue:forUndefinedKey:]: this class is not key value coding-compliant for the key showsVerticalScrollIndicator .


EDIT:
It worked! I typed a wrong space!
 
Top