Android Question DJI DRONE Phantom 4 Pro + don't connect

Discussion in 'Android Questions' started by Roberto P., May 6, 2018.

Similar threads

B4A Library DJI Drones
B4J Library [B4X] Ryze/DJI Tello drone SDK -app
B4A Question DRONE: DJI Tello
B4A Question read bar-code width DJI Drone
B4A Question DJI Drones read video info
  1. Roberto P.

    Roberto P. Well-Known Member Licensed User

  2. DonManfred

    DonManfred Expert Licensed User

    you need to be logged in

    djiversion451.jpg
     
  3. Roberto P.

    Roberto P. Well-Known Member Licensed User

    of course... I'm logged in and I've downloaded everything.
     
  4. DonManfred

    DonManfred Expert Licensed User

    Does it work now to find the 4.5.1 download?
     
  5. Roberto P.

    Roberto P. Well-Known Member Licensed User


    I downloaded and checked, but I only see Gradle's Jar. See image.

    or am I wrong ?!
     

    Attached Files:

  6. DonManfred

    DonManfred Expert Licensed User

    Search for AAR, not jar

    Away from this: You should create a new Thread for this NEW issue.

    Anyway: Why are you trying to download 4.5.1 even if you know it will not work with your Drone (Based on the answer from the Support)?
     
  7. Roberto P.

    Roberto P. Well-Known Member Licensed User

    Not found! See picture

    I'm trying to download because I want to do this last test before throwing the drone out of anger.

    thank
     

    Attached Files:

  8. DonManfred

    DonManfred Expert Licensed User

  9. Roberto P.

    Roberto P. Well-Known Member Licensed User

    I did not know this repository and it is not specified in the DJI support.

    I do not know if I have to turn this format into Jar?

    thank you for your availability and kindness.
     
  10. DonManfred

    DonManfred Expert Licensed User

    no. must be copied to the additional libs folder.
     
  11. Roberto P.

    Roberto P. Well-Known Member Licensed User

    ok. I have to replace the reference to the example library

    from

    #AdditionalJar: dji-sdk-provided-4.4.1

    to
    #AdditionalJar: dji-sdk-4.5.1.aar

    it's correct?

    thank again
     
  12. DonManfred

    DonManfred Expert Licensed User

    no. See the example code from the Drone thread. The #additionaljar must be other.....
    Note that you need B4A 8 for it.
     
  13. DonManfred

    DonManfred Expert Licensed User

    My last answer here as i´m not interested to spent more time on your issues. I just accepted that you have a Drone which does not work with the SDK.

     
  14. Roberto P.

    Roberto P. Well-Known Member Licensed User

    I understand that you do not want to spend more time and I thank you.

    if this drone does not work I'll have to buy another one that supports SDK!
     
  15. DonManfred

    DonManfred Expert Licensed User

    unfortunately this seems to be true.
    I feel with you and i can understand you are trying all you can.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice