Android Question Error compile NFC project and SDK version

ovt001

Member
Licensed User
Hi,
when I compile the project Advanced NFC created by Erel, I receive this error:

"adb: failed to install NFCAdvanced_RAPID_DEBUG.apk: Failure [-26: Package b4a.example new target SDK 19 doesn't support runtime permissions but the old target SDK 26 does.]"

can somebody help me to understand / slove this issue.

Thank you
O.
 

DonManfred

Expert
Licensed User
adb: failed to install NFCAdvanced_RAPID_DEBUG.apk: Failure [-26: Package b4a.example new target SDK 19 doesn't support runtime permissions but the old target SDK 26 does.]"
1. You should ALWAYS use your own packagename to distinguish the apps installed.

In this case you are trying to install an app (b4a.example) with targetsdk set to 19 but the old installed b4a.example app has Targetsdk 26.

Remove the old app, install your new then.

But best is to NEVER use the same package with two different apps.

You always should start with giving every app a unique packagename.
 

ovt001

Member
Licensed User
Hi DonManFred,
Ok, I rename the b4a.expample to b4a.MyOwnPackageName and its works fine.
thank you
O.
 
Top