iOS Question error loading bitmaps in debug

Discussion in 'iOS Questions' started by Albi, Jun 18, 2015.

  1. Albi

    Albi Active Member Licensed User

    Hello,
    When I run my app in debug, it returns the error messages

    Error loading bitmap: Error opening stream: The operation couldn’t be completed. No such file or directory

    This line writes once for each png found in a layout during the line (eg)
    Code:
    Page1.RootPanel.LoadLayout("1")
    However, it runs fine in release mode.
    Renaming the png's and resyncing works for images in layout files, before it reoccurs after some time. Renaming does not work for images in the tabbar. Leaving images in the tabbar causes it to crash in debug mode (same error message, but adds the line that it occurs), while in release mode it builds fine.

    Have tried restarting b4i, restarting computer, cleaning files, cleaning project.

    Any help would be great!
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Try to uninstall the app from the device and then install it again.
     
  3. Albi

    Albi Active Member Licensed User

    I've renamed the files and resynced so it's ok at the moment. If it happens again i will uninstall+reinstall.
     
Loading...