Android Question fail to connect B4A to phone by USB cable

Discussion in 'Android Questions' started by sirjo66, Jul 2, 2014.

  1. sirjo66

    sirjo66 Well-Known Member Licensed User

    Hello,

    I'm trying to connect B4A to my "Samsung S 3 Mini" by USB port, but when I run program, B4A don't connect to it.

    On my phone, I have enable "debug USB" option, and then I have connected the phone to the PC. On phone I see a little icon "usb" on top-left of the screen, and if I try to read/write files into phone it works, so I think that the drivers on PC works perfectly.
    But when I run B4A, I select "Debug (legacy)" option, then "Compile & Run", it compile, but then appeare a message that tell me "No device found. Please start an emulator".

    How I can do it ??

    On my phone, is it correct that appeare only one icon ("usb" icon) or need to appeare also a little icon "debug mode" ??

    Thanks
    Sergio
     
  2. pjo12345

    pjo12345 Active Member Licensed User

    Hi there!
    I had the same problem. Uninstall Java JDK and Android SDK and then install again. Has helped me. Maybe it helps you too.
     
  3. Erel

    Erel Administrator Staff Member Licensed User

    katrad likes this.
  4. sirjo66

    sirjo66 Well-Known Member Licensed User

    Thanks Erel, it works very well !!

    Best regards
    Sergio
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice