Android Question File installation on the device error after update to 9.01

sdesan

Member
Licensed User
A little problem.
After install new version it starts this problem

******************************
B4A Versione: 9.01.2
Java Versione: 11
Analisi del Codice. (0.54s)
Building folders structure. (0.05s)
Compilazione del codice. (0.91s)

File ObsucastorMap.txt creato nella cartella Objects.
Compilazione del codice di layouts (0.09s)
Organizzazione Librerie. (0.00s)
Generazione file R. (7.47s)
Compilazione del codice Java prodotto. (20.59s)
Conversione byte code - ottimizzazione dex. (38.17s)
Packaging files. (4.77s)
Copia risorse delle librerie (0.29s)
Found 21 resource files.
Firmo il package file ( chiave privata ). (8.58s)
ZipAlign file. (2.31s)

Installazione file sul dispositivo. Error
Impossibile trovare il file specificato


******************************

Error is on installing to device connected via B4A bridge. (same error if I disconnect bridge and connect by usb cable)
I don't understand if is a path misconfiguration or any file missing or what
If I manually copy apk file on device it works without problem
 

Star-Dust

Expert
Licensed User
Maybe it can't get the apk file because it is in a folder that requires special privileges?
Try running B4A in administrator mode
 

sdesan

Member
Licensed User
Thank you for your answer Star-Dust
I tried also tu run B4A ad administrator whith same error.
I don't think is a right folder problem because apk compiled file is written whitout any problem
I'm unable to understand what is the file missed. I don't know if there is a complier or error log file in same place
apk works but i need to compile, copu on device and launch/install apk every time :oops:
 

sdesan

Member
Licensed User
Finally i found the problem.
File missing is adb.exe
Avast antivirus delete it during installation or extracting sdk-tools-windows-xxxxxx.zip (without notice) :(
Casually i found it in virus basket
I had to activate an exception in avast on adb.exe
 
Top