Android Question Google Maps - API 28

Powie

Member
Licensed User
I tried to update the target SDK version to 28. Then my app crashes if the google maps api map fragment is ready. If i switch back to target sdk 26, all is ok again. GoogleMaps V2.02 is used.

The displayed error doesn't help me....:


java.lang.NoClassDefFoundError: Failed resolution of: Lorg/apache/http/ProtocolVersion;
at gw.b:)com.google.android.gms.dynamite_mapsdynamite@17785081@17.7.85 (100400-253824076):3)
at gt.a:)com.google.android.gms.dynamite_mapsdynamite@17785081@17.7.85 (100400-253824076):3)
at gv.a:)com.google.android.gms.dynamite_mapsdynamite@17785081@17.7.85 (100400-253824076):14)
at com.google.maps.api.android.lib6.drd.ak.a:)com.google.android.gms.dynamite_mapsdynamite@17785081@17.7.85 (100400-253824076):6)
at fx.a:)com.google.android.gms.dynamite_mapsdynamite@17785081@17.7.85 (100400-253824076):22)
at fx.run:)com.google.android.gms.dynamite_mapsdynamite@17785081@17.7.85 (100400-253824076):8)
Caused by: java.lang.ClassNotFoundException: Didn't find class "org.apache.http.ProtocolVersion" on path: DexPathList[[zip file "/data/user_de/0/com.google.android.gms/app_chimera/m/00000075/MapsDynamite.apk"],nativeLibraryDirectories=[/data/user_de/0/com.google.android.gms/app_chimera/m/00000075/MapsDynamite.apk!/lib/arm64-v8a, /system/lib64, /system/product/lib64]]
at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:134)
at java.lang.ClassLoader.loadClass(ClassLoader.java:379)
at ab.loadClass:)com.google.android.gms.dynamite_dynamiteloader@17785081@17.7.85 (100400-253824076):4)
at java.lang.ClassLoader.loadClass(ClassLoader.java:312)


Ideas?
 
Top