Android Question Installation Missing Jar File

tsimard

New Member
Licensed User
Hello. I am a returning B4A user and am trying to install the new full version. I have tried several times and all seems to install ok, including the acceptance of the license. However, when first executed, B4A gives an error message 'Missing jar file for library: Package.xml'. I can see this file in the configuration paths for android.jar and Additional Libraries. Any suggestions - Stuck.
 

DonManfred

Expert
Licensed User
I can see this file in the configuration paths for android.jar and Additional Libraries
??? What do you see in Tools Configure Paths?

- Are you using the B4A SDK Manager?
- If yes: Please POST
A: The path to the android.jar from tools configure paths
B: The path of the bat file in the 1st edit field in the B4A SDK Manager
- Did you setup a new SDK or are you reusing an old SDK Folder?

I suggest to setup a NEW SDK. Start with a blank folder and follow the instructions here:
https://www.b4x.com/b4a.html#installation
 

tsimard

New Member
Licensed User
Thank you for your suggestions. I'll try to establish an new SDK file folder, however this time, I will use the pre-configured zipped folder first. It's a good place to start, then I may go back to the SDK Manager download process. Right now, the android folder is about 3.7GB. That seems a bit large to me. We'll see. Thank you again. BTW, the pointers in the tools path configuration page for were as suggested (jar and bat). I'll let you know what happens.
 

tsimard

New Member
Licensed User
Hello Don,
A new SDK, smaller (0.5 GB), yields the same error - 'missing jar file for library: Package.xml'. So...,

To answer your questions, Yes I am using the B4A SDK Manager. The path to the android.jar is 'c:\android\platforms\android-28\android.jar' and the file is there and the path to the skdmanager.bat file is 'c:\android\tools\bin\sdkmanager.bat' and this .bat file is there too.

My previous B4A system (6 years ago and worked great) is on a separate computer. I'v tried to load this version on two different, virgin Win10 system and am having the same problem. I've used the installation html document you suggested in all cases. I'm obviously doing something dumb, but I don't see it. Any help or suggestions you may have is very much appreciated. Thank you.
 

tsimard

New Member
Licensed User
Don, Success! It is now working. In the 'Additional Libraries' in the Path Configuration page, I used, as I thought the documentation suggested, a path to the android tools library. I noticed however, on my old B4A 2.30, that 'C:\Program Files (x86)\Anywhere Software\Basic4android\Libraries' was used. Using this path ('Program Files - Anywhere Software') satisfied the initialization problem. I don't quite know exactly why it is working, but it is. Thank you Don very much for your kind help. Tom Simard, Suncoast Systems, Inc.
 
Top