Italian Installazione di b4a - windows 32 bit -

atomic

Member
Buongiorno a tutti.
Ho usato b4a qualche tempo fa, e non ho avuto nessun problema. Avevo collegato il mio Hisense..e funzionava tutto alla perferzione..mi collegavo e installavo anche l'app sul cellulare.
Oggi scarico la versione 9.50 (A) Trial, ma nn riesco a configurare nulla...
per cortesia potreste dirmi i vari passaggi, e magari indicarmi anche i link delle risorse da installare.
Ho installato java (32 bit)
ho scaricato sdk android
ho avviato avdmanager
ma ho problemi con la connessione al mio cellulare samsung j6 plus
Vorrei ricominciare da zero
quindi vi chiedo la cortesia di indicarmi passo passo cosa fare
Intanto faccio altre prove
Grazie a tutti
 

atomic

Member
Allora, ok
avevo fatto confusione con le cartelle scompattate...
ora mi ritrovo con gli stesse cartelle indicate sul sito quindi è tutto ok ho avviato anche l'sdk manager ed installato tutto quello che era raccomandato accettando le varie licenze
Solo che non riesco ne ad avviare un emulatore
e nemmeno riesco a collegare il mio samsung galaxy j6 plus usb, nonstante windows lo vede perfettamente ed è cmq impostato come sviluppatore ed ha il debug attivato
Mi aiutate per cortesia ?
Grazie
 

Sagenut

Well-Known Member
Licensed User
Nelle impostazioni di B4A hai impostato la cartella dove è installato l'SDK Android e la cartella con l'SDK Java?
La guida di installazione dovrebbe essere abbastanza chiara comunque.
 

atomic

Member
Grazie per avermi risposto
si credo di aver configurato tutto
nn riesco a capire
eppure qualche anno fa non ho avuto nessun problema
 

Attachments

Sagenut

Well-Known Member
Licensed User
Nell'immagine mi pare che hai tentato di collegare il Designer in modalità WYSIWYG, giusto?
Per quello mi pare che sia necessario avere installato il B4A-BRIDGE sul telefono.
Hai provato a scaricare un esempio dal forum ed eseguirlo in debug per vedere se rileva il telefono per l'installazione?
 
Last edited:

atomic

Member
Nell'immagine mi pare che hai tentato di collegare il Designer in modalità WYSIWYG, giusto?
Per quello mi pare che sia necessario avere installato il B4A-BRIDGE sul telefono.
Hai provato a scaricare un esempio dal forum ed eseguirlo in debug per vedere se rileva il telefono per l'installazione?
ma wyswyg è l'unica opzione! giusto?
con b4a-bridge devo per forza collegarmi con una wifi sembra...o no?...nn ci sto a capire più nulla
 

Sagenut

Well-Known Member
Licensed User
Con il cellulare collegato al pc con il cavo usb:
apri il Prompt dei comandi di windows come amministratore e poi prova
B4X:
cd\android\platform-tools
adb devices
Sul cellulare dovrebbe apparirti una richiesta di autorizzazione, se non l'hai già data con il Consenti Sempre spuntato.
Nel caso dai il consenso e poi esegui di nuovo il comando
B4X:
adb devices
Se non ti risponde con il seriale del cellulare c'è qualcosa che non và.
 

Sagenut

Well-Known Member
Licensed User
Allora credo che ci sia un problema a livello di driver del cellulare.
Te lo vede come memoria di massa ma non in Modalità Debug USB.
Prova a far pulizia nei driver e poi a farli reinstallare dal sistema solo collegando il cellulare.
Prova anche a cambiare tra le varie porte USB che hai a disposizione.
Devi arrivare ad ottenere il seriale con la procedura che ti ho indicato.
 
Last edited:

atomic

Member
Grazie, farò altre prove.
Ho provato con un altro cellulare...e va bene
avevo già cambiato le porte...ma niente
può darsi pure che sia da impostare qualche altra impostazione sul galaxy j6 plus che adesso non so
ma intanto grazie davvero
ps
ti prego continua ad aiutarmi
:)
 

Sagenut

Well-Known Member
Licensed User
Almeno ora sai che il problema è solo relativo al tuo cellulare/drivers.
Come ti ho detto lavora sulla pulizia e reinstallazione dei suoi drivers per ora.
 

atomic

Member
Grazie, scusami se non ti ho risposto subito.
Nel frattempo ho realizzato una pagina web...
Il mio cellulare continua a non vederlo...farò altre prove.
Grazie ancora
 
Top