Italian Permessi installazione

Discussion in 'Italian Forum' started by shadow, May 8, 2019.

  1. shadow

    shadow Member Licensed User

    Un saluto a tutti, da molto tempo che non usavo B4A, solo qualche settimana fa ho realizzato un app per alcuni amici. Fino a ieri avevo la versione 5.80 e filava tutto liscio, stamattina ho deciso di acquistare la versione 9. Stasera nel provare a compilare l'app con la nuova versione si è presentato qualche problema per installarla al cellulare. Ho letto un pò per i vari permessi , ed ho aggiunto il permesso del pacchetto più la scrittura su memoria, il fatto è che se installo l'app dopo averla compilata, si installa e funziona. Se provo invece ad installare apk, non la installa... qualcuno ha riscontrato un problema simile?
     
    Last edited: May 8, 2019
  2. Star-Dust

    Star-Dust Expert Licensed User

  3. shadow

    shadow Member Licensed User

    Ho seguito un pò il tutorial di Erel, per i permessi basta solo aggingerli al Mainfest?
    Nell'altra discussione che ho aperto in "Android Questions" mi è hanno suggerito di cambiare targetSdkVersion = "26" con targetSdkVersion = "22", ma il rislutato non è cambiato.
     
  4. Star-Dust

    Star-Dust Expert Licensed User

    Sicuramente non dipende dal manifest.
    Altrimenti non installarebbe mai. Ma se ti installa collegato con OTG o con il Bridge allora il problema è un altro.

    Sotto questo aspetto non è cambiato nulla dalle versioni precedenti.
     
  5. shadow

    shadow Member Licensed User

    Visto che ho installato la nuova versione senza rimuovere la vecchia, ho chiesto anche ad Erel se poteva dipendere da questo. Anche perché non mi ha chiesto l'attivazione all'avvio, ma mi ha risposto che non è quello il problema. Quello che non capisco è perché dal Bridge si installa regolarmente e funziona senza problemi, mentre se sposto l'app nella memoria del cellulare, alla fine non la installa. Essendo un app che ho pubblicato gratuitamente su un forum, è stata provata da più persone, tutte con lo stesso problema. Mentre con la versione precedente di B4A dopo compilato il file apk, si installava senza problemi. Nell'immagine che allego si può vedere il file in esecuzione dopo la compilazione e l'installazione da Bridge, e successivamente la prova di installazione del file apk dalla memoria del cellulare.

    [​IMG]
     
  6. Star-Dust

    Star-Dust Expert Licensed User

    Il nonno abbiamo sufficienti elementi per aiutarti. vedi se il problema consiste nel autorizzazione del sistema installare software da fonti esterne al market

    Hai cambiato smartphone? Hai abilitato io menù sviluppatore? Hai attivato il debug USB?

    l'errore è indicato sempre che il tuo dispositivo non abbia le visite necessarie per installare. Questo può succedere se la app for x86 anziché per arm. oppure se il requisito minimo e avere una schermo Maxi il dispositivo non è a disposizione. Un altro caso può essere quando le SDK minimo Massimo tagliano fuori il tuo dispositivo
     
  7. shadow

    shadow Member Licensed User

    Non ho cambiato smartphone, sempre stessa procedura per la prima installazione, cioè col Bridge tramite Wifi. Per quanto riguarda l'app, non fa altro che scaricare un file dal web con i dati statistici, ma quello che non capisco è perché da bridge si installa e gira regolarmente...
     
  8. Star-Dust

    Star-Dust Expert Licensed User

    Le ragioni possono essere tante e tu dai poche informazioni per capirlo.
     
  9. shadow

    shadow Member Licensed User

    Che informazioni servirebbero?
     
  10. LucaMs

    LucaMs Expert Licensed User

    Tanto per non lasciare dubbi: installazione tramite bridge in modalità Release?
     
  11. shadow

    shadow Member Licensed User

    Si, allego un'immagine dove ci sono più dettagli...

    [​IMG]

    [​IMG]
     
  12. shadow

    shadow Member Licensed User

    Ho apportato questa piccola modifica al codice:
    [​IMG]

    Potrebbe essere apk generato che ha qualche problema (anche se in fase di compilazione non da errori)?
     
    Last edited: May 10, 2019
  13. Star-Dust

    Star-Dust Expert Licensed User

    Hai installato il Programma Play Protect?
    Probabilmente è quello che ti blocca l'installazione
     
    shadow and sirjo66 like this.
  14. shadow

    shadow Member Licensed User

    Si, ho Play Protect, se fosse quello non capisco perché compilato con la vecchia versione non lo bloccava.
     
  15. shadow

    shadow Member Licensed User

    Appena provato, installata disattivando Play Protect... Grazie. A tutto pensavo tranne che a quello.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice