B4J Question Is 3D acceleration required for UI apps?


Licensed User
Longtime User
As I still have a speed issue with the IDE, I tried the suggestion someone made on the forum to disable 3D acceleration in my virtual machine. Wonder, oh wonder the IDE is smooth as silk!

However, when I run a program, none of the controls are visible. They are on the form (e.g. when I click on where a combo is, I'll get the dropdown.)

With 3D acceleration:



Without 3D acceleration:



The problem is the IDE is virtually unusable when 3D acceleration is enabled. (key strokes take up to 3 seconds).

Note: UI apps using the depreciated scene builder do work with the 3D acceleration disabled (like the controlsFx demo)


Licensed User
Longtime User
I'm using the MetroLight - Light Theme (default?) in Themes Manager.

But joy, joy! Using the #VirtualMachineArgs: -Dprism.order=sw worked.

Just for reference for anyone else that ran into the speed issue in the IDE in a virtual machine (vmware)

1. I've changed the CPU settings from 1 CPU, 8 Cores -> 1 CPU, 2 Cores (counter intuitive, but it seems vmware starts using emulation of cores at a certain point, which slows down the emulator)
2. Made sure the Memory is not above the maximum setting (changed it from 16GB to 8GB, again some swapping occurs otherwise)
3. Disabled 3D acceleration
4. Added #VirtualMachineArgs: -Dprism.order=sw in the B4J app.

For me, this results in a much smoother IDE in vmware, AND I can still run the UI apps.

I hope it may be usefull to someone else.
Upvote 0