B4J Question Is there a difference between Media Player in Debug Mode and Standalone ?


Licensed User
Hello Community,

I build a standalone version of my App with the integrated builder on a Windows 10-x86-64 VM. When I run the App it starts normaly. When I press a button where I play a mp3 file via MediaPlayer it quits without any error message. In the Windows logs I can not see anything.
When I run the App in Debug Mode everything works as expected.

Where is the difference between Media Player in Debug Mode and Standalone?
How can I catch such an error that the App does not quit silently?

Best regards



Licensed User
Yes, I mean release mode.

I tried run_debug.bat.


C:\Users\info\Documents\b4x\B4J\Objects\temp\build>cd bin

C:\Users\info\Documents\b4x\B4J\Objects\temp\build\bin>java.exe @release_java_modules.txt  -m b4j/b4j.B4XDicy.main
MainPage Init
DataProfileFolder path: C:\Users\info\AppData\Roaming\Dicy
MainPage create
Imprint Page init
ManageProfile init
Load Settings
Profile File Dicy_Profiles.txt exist
Active Profile: EuroLotto
Profile found which is Active
Call B4XPages.GetManager.LogEvents = True to enable logging B4XPages events.
b4xmainpage._btnroll_click (java line: -1)
java.lang.UnsupportedOperationException: Unsupported protocol "jrt"
        at javafx.media/com.sun.media.jfxmedia.locator.Locator.<init>(Unknown Source)
        at javafx.media/javafx.scene.media.Media.<init>(Unknown Source)
        at b4j/anywheresoftware.b4j.objects.MediaPlayerWrapper.Initialize(Unknown Source)
        at b4j/b4j.B4XDicy.b4xmainpage._btnroll_click(Unknown Source)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.base/java.lang.reflect.Method.invoke(Unknown Source)
        at b4j/anywheresoftware.b4a.BA.raiseEvent2(Unknown Source)
        at b4j/anywheresoftware.b4a.BA$1.run(Unknown Source)
        at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$10(Unknown Source)
        at java.base/java.security.AccessController.doPrivileged(Native Method)
        at javafx.graphics/com.sun.javafx.application.PlatformImpl.lambda$runLater$11(Unknown Source)
        at javafx.graphics/com.sun.glass.ui.InvokeLaterDispatcher$Future.run(Unknown Source)
        at javafx.graphics/com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
        at javafx.graphics/com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(Unknown Source)
        at java.base/java.lang.Thread.run(Unknown Source)

This looks the same as from my other thread where I try my app on Linux.

Is the location from the mp3 file wrong?
Upvote 0


B4X founder
Staff member
Licensed User
Longtime User
Upvote 0