iOS Question Issues deploying on a physical device (related to M1 processor ?)

wl

Well-Known Member
Licensed User
Setup:
- Mac Mini M1 (16GB - 1 TB) latest BigSur, latest XCode (12)
- AC 2 set up (with automated tools enabled)
- version 7.5 of Mac Builder
- Latest Windows ARM running Parallels 17, hosting b4i 7.5

Issue:
- when deploying to simulator all is OK, but can't deploy to physical device connected through USB (AC 2)

Details:
- when running the builder without sudo
-> "code sign wants to access key "B4i" in your keychain. To allow this, enter the "b4i_default-db" keychain password"

- when running the builder with sudo
B4X:
B4i Version: 7.50
Parsing code.    (0.00s)
Building folders structure.    (0.01s)
Compiling code.    (0.01s)
Building designer app.    (0.00s)
Building Xcode project.    (0.12s)
Preparing project for builder.    (0.09s)
    Project size: 0.24 MB
Sending data to remote compiler.    Error
Out: Command line invocation:
    /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -configuration Release PRODUCT_NAME=B4i-Bridge CONFIGURATION_BUILD_DIR=/Users/wim/Documents/B4iBuildServer/UploadedProjects/<user id>/Payload "CODE_SIGN_IDENTITY=iPhone Distribution: Wim Lambrechts (6T4HF6S2R4)" "OTHER_CODE_SIGN_FLAGS=--keychain <user id>" PROVISIONING_PROFILE=9468f969-9919-4aa0-8fa8-01c114503122 -arch armv7 -arch arm64

User defaults from command line:
    IDEPackageSupportUseBuiltinSCM = YES

Build settings from command line:
    ARCHS = armv7 arm64
    CODE_SIGN_IDENTITY = iPhone Distribution: Wim Lambrechts (6T4HF6S2R4)
    CONFIGURATION_BUILD_DIR = /Users/wim/Documents/B4iBuildServer/UploadedProjects/<user id>/Payload
    OTHER_CODE_SIGN_FLAGS = --keychain <user id>
    PRODUCT_NAME = B4i-Bridge
    PROVISIONING_PROFILE = 9468f969-9919-4aa0-8fa8-01c114503122

note: Using new build system
note: Using codesigning identity override: iPhone Distribution: Wim Lambrechts (6T4HF6S2R4)
note: Planning build
note: Analyzing workspace
note: Constructing build description
note: Build preparation complete
/Users/wim/Documents/B4iBuildServer/UploadedProjects/<user id>/B4iProject.xcodeproj: warning: The iOS deployment target 'IPHONEOS_DEPLOYMENT_TARGET' is set to 8.0, but the range of supported deployment target versions is 9.0 to 14.5.99. (in target 'B4iProject' from project 'B4iProject')
error: "B4iProject" requires a provisioning profile. Select a provisioning profile in the Signing & Capabilities editor. (in target 'B4iProject' from project 'B4iProject')


Error: ** BUILD FAILED **

The same setup is working flawlessly on my old Mac Mini x86 (having done, redone and redone again all steps - including reinstalling the entire OS on both the x86 and the M1 machine)
It *should* be possible to get it running on an M1 (thanks @mike2ppc for your continuous support !)

Related: https://www.b4x.com/android/forum/t...eychain-password-required.132386/#post-836641 (same issue without solution)
and (my old post): https://www.b4x.com/android/forum/t...import-unknown-format-in-import.133821/page-2
 
Last edited:

wl

Well-Known Member
Licensed User
This is what I always got on the mac when trying to build a B4Build-bridge app (running the B4iBuilder without sudo)


Trying to build the B4i project in Xcode and playing with the signing settings getting the same...

Found an error in the provisioning profile ??
 

Attachments

  • Untitled.png
    Untitled.png
    268.4 KB · Views: 30
  • Untitled.png
    Untitled.png
    54 KB · Views: 29
  • Capture.JPG
    Capture.JPG
    37.5 KB · Views: 30
Last edited:
Upvote 0
Top