B4J Question jAWTRobot i7 vmWare 15 RobotPaste problem

Discussion in 'B4J Questions' started by ThRuST, Jan 4, 2019.

  1. ThRuST

    ThRuST Well-Known Member Licensed User

    I've been doing tests with jAWTRobot.RobotPaste and discovered the pasting does not work 100% with my new Intel Core i7 9700 3.6 MHz CPU running at 4.7GHz. Tested on Mac OSX El Capitan and vmWare Workstation 15. I wrote a little test program so you all can try it yourself.

    Please do some testing and report your own result. Thanks

    My own results:
    CTRL_V pasting works correctly on Windows 10 Home.
    META_V pasting works on Windows 10 Home.
    META_V pasting works sometimes and sometimes it only pastes "v" on Mac OSX El capitan (vmWare 15).

    I have tested different keyboard layouts and also set this in vmWare
    jAWTRobot version 1.55 was used.

    Not tested on a real Mac and not Mojave since JavaFX is not fully supported yet.
     

    Attached Files:

    Last edited: Jan 4, 2019
  2. ThRuST

    ThRuST Well-Known Member Licensed User

    upload_2019-1-4_16-27-7.png

    if possible, please try this on a real Mac anyone.
     
    Last edited: Jan 5, 2019
  3. Roycefer

    Roycefer Well-Known Member Licensed User

    I'm not at my computer now but I will look into this tomorrow. Have you tested META_V with your own fingers? The ATRobot API should be duplicating exactly what your fingers are doing.
     
  4. ThRuST

    ThRuST Well-Known Member Licensed User

    I have used the official default keys in vmWare Workstation 15 in Mac OSX El Capitan for these tests. I suggest that you download it yourself and give it a try with my test application. Please note that I have tested this before with my older computer that used a AMD Phenom II 4 cores 3.4 GHz CPU. I was using vmWare workstation 10 with El Capitan. My latest test was with my newly buildt system which is a Intel core i7 9700 8 cores 3.6 GHz running at 4.7GHz (OC). Mostly default options in vmWare.
    English and Swedish keyboard layouts. Default loaded settings in OSX. Worth to mention is that in my project it pastes "v" on Mac all the time but in the test app it's random. I use RobotPaste("META_V") in my project Athena to paste the loaded strings from the database, that is pasted at the cursor position when an item is selected from the floating menu. This works well on PC but pastes only a "v" on Mac. I guess I've come to a point were I need beta testers, but for now I still rely on separate examples. I have posted a new question about simulating key press just to make CTRL+V work so I can call any solution to make it work, in this case on Mac since it works perfectly on PC. Let's trace this issue on Mac. I really want the Mac version to work because I plan to create a custom floating menu for Mac that will be most useful. I plan to release my project in a few month. You can all enjoy using it then once every obstacle is passed. I await your reply, please look into this when you have the time.
     
  5. Roycefer

    Roycefer Well-Known Member Licensed User

    This sounds to me like an issue with your setup, not an issue with the library. I went through a bug-fixing period with numerous Mac users on the RobotPaste methods and the outcome worked well on their machines. It sounds like your virtual machine key mappings are off or something.
     
  6. ThRuST

    ThRuST Well-Known Member Licensed User

    I was hoping that 5-10 people could confirm this by testing my little test application on their Macs within a few hours. But sadly my question was not as popular as ABMaterials questions who get 35000+ hits :) Anyway, your jAWTRobot library is great and it worked before, so it might be a mapping issue in my vmWare setup.
    I am awaiting a test report from a contact who owns a real new MacBook pro, so it would be great to collect more reports. I will reinstall vmWare and set it up anew to see if that fixed the problem. Btw why is it called a META key? I've read that it can be the ESC key on some computers but as well all know CTRL+c,v is copy and paste on PC and Apple key+c,v is copy and paste on Mac. In vmWare PC users will have to use the Windows key + c,v to simulate the Apple key. Message to new visitors is : Please try my test app on Macs and confirm that it works without any problems, and in that case it won't it might be the mapping in the emulator.
     
  7. ThRuST

    ThRuST Well-Known Member Licensed User

    I am now reinstalling vmWare and are setting it all up when this came up. This means it's important to go through settings for keyboard to make it work correctly.

    upload_2019-1-6_13-58-45.png
     
    joulongleu likes this.
  8. David Meier

    David Meier Active Member Licensed User

    Hi ThRuST

    I step in a bit late. Nevertheless: I tried out your suggestions on my Mac OSX 10.14.3:

    Not working:
    AWTRobot.RobotSpecialKeyCombo("ctrl_v")

    Working:
    AWTRobot.RobotPaste(fx.Clipboard.GetString)

    The documentation says that "meta_v" should work on all platforms. With me it did not.

    What was important with my solutions, that I used fx.Clipboard.GetString as the input string.

    Kind regards

    David
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice