B4J Question jRDC2 connection to MSSQLServer failed

Martin Fernandez

Member
Licensed User
Hi, I'm using jRDC2 to connect to MSSQLServer DB in all my projects with no problems in several servers, today after installing all the requirements and from jRDC2 source running in Debug mode (I tested in Release too), I tested using the browser with localhost and this message appears:
RemoteServer is running (12/20/2019 14:47:49)
Error fetching connection.

In Logs windows appears:
WARNING: Having failed to acquire a resource, com.mchange.v2.resourcepool.BasicResourcePool@75d2da2d is interrupting all Threads waiting on a resource to check out. Will try again in response to new client requests.

My scenario:
SQL Server 2014 running on a VPS Server (first time installing jRDC2 in this server)
Java jdk1.8.0_231 installed
Tried with DriverClass=net.sourceforge.jtds.jdbc.Driver (always use this) and changed to DriverClass=com.microsoft.sqlserver.jdbc.SQLServerDriver with the same result.

I think is something with the VPS Server.

Someone can help me, please?

Thanks

************** RESOLVED ****************
I didn't copy all the files including jdbc driver
 
Last edited:
Top