Android Question Need Help after reloading SDK's

JohnC

Well-Known Member
Licensed User
I could not get the SDK 28 Emulator to run, so I had the smart idea to reinstall the SDK's.

So, I downloaded the two files (command line tools + resources on this page: https://www.b4x.com/b4a.html) and everything went OK and I was able to create a SDK 28 image and it booted up!

Great!......Well not so quick..

I then tried to compile my app and send it to the emulator and I got all of these missing SDK files (maven).

If I had to take a guess, I would say these errors were caused because one of the two files I downloaded above (tools + resources) is setup to use the new AndroidX sdks, but since I am running B4A 9.01 and not 9.3 this is causing a problem.

So, am I right in guessing that the "resources.zip" file is the one configured for the android X and causing my issues? And if so, would it be possible to get an older version that is NOT configured for Androidx sdks?

The reason is that I do not wish to upgrade to B4A 9.3 right now because I have seen others post problem compile their apps after upgrading to 9.3 and I just can't afford to spend hours right now debugging "new" errors caused by an upgrade. I'll eventually upgrade, but I just don't have the time now to deal with any unplanned surprises.

So, is it possible to send me an older copy of the resources.zip file that will work with my B4A 9.01?
 
Last edited:

Erel

Administrator
Staff member
Licensed User
The reason is that I do not wish to upgrade to B4A 9.3 right now because I have seen others post problem compile their apps after upgrading to 9.3 and I just can't afford to spend hours right now debugging "new" errors caused by an upgrade.
You should upgrade to v9.30. v9.30 is 100% backward compatible.
 
Top