iOS Question New announcement from appstore

Giusy

Active Member
Licensed User
Hi,
This announcement appears on the appstore:

We remind you that, starting from March 27th 2019, all new apps and updates for iPhone or iPad apps, including universal apps, will have to be developed with the iOS 12.1 SDK and support iPhone XS Max or iPad Pro (3rd generation) of 12.9 inches. Screenshots for these devices will also be required. All new apps and app updates for Apple Watch will need to be developed with the watchOS 5.1 SDK and support Apple Watch Series 4.

Do our app continue to be compatible or do they need to be modified?
Thanks
 

Erel

Administrator
Staff member
Licensed User
If you are using the hosted builder then your app is developed with iOS 12.1 SDK. If using a local builder then make sure to update to Xcode 10.1.
support iPhone XS Max or iPad Pro (3rd generation) of 12.9 inches
Current version of B4i doesn't add launch images for iPhone XS Max. The next version will add such images. The app will run properly without these images (it will run in a compatibility mode), so I'm not sure whether it is a strict requirement or not. We will know in a few days.

Anyway, you can add those images by unzipping the attached file and copying the files to your app File\Special folder.
 

Attachments

Sasuke Sama

Active Member
Licensed User
If you are using the hosted builder then your app is developed with iOS 12.1 SDK. If using a local builder then make sure to update to Xcode 10.1.

Current version of B4i doesn't add launch images for iPhone XS Max. The next version will add such images. The app will run properly without these images (it will run in a compatibility mode), so I'm not sure whether it is a strict requirement or not. We will know in a few days.

Anyway, you can add those images by unzipping the attached file and copying the files to your app File\Special folder.
Do we need to but our own photos based on these? Or just unzip it and forget about it
 
Top