Android Question New app gives "App not installed" error

Discussion in 'Android Questions' started by Arun, Jul 27, 2015.

  1. Arun

    Arun Member Licensed User

    Hi!

    Fyi, I am testing on a OnePlus One Model A0001 with OS Cyanogen 12.0.YNG1TAS213

    In the TRIAL version:
    I downloaded and checked out the treeview example, the TwoDScroll demo and the ScrollView2D, all of which were installed and worked successfully on my device.

    I then created an app to download files using httputils2 and string functions libraries which also worked beautifully on the same device. To neaten the app, I tried to insert a ProgressBar. This never worked, so i posted a question on the forum (see http://www.b4x.com/android/forum/th...ar-display-with-httputils2.56445/#post-355235)

    Not getting a response after posting the code, I attempted some modifications. When I tried running the app, i was informed that the Trial version does NOT support these libraries. (http://www.b4x.com/android/forum/threads/string-functions.10365/page-10#post-355270)

    I then purchased the Enterprise version on Saturday.

    Now when I run ANY app, it remote compiles to the phone, but when I click on Install, it says "App not installed".

    I created a new app, this gives me the same error.

    I am at a loss as to how to proceed, what to check and where to check.

    Please let me know if you need further details.

    Thanks!
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Are you using B4A-Bridge or USB debug mode? Have you tried to uninstall the app before you run it?
     
  3. KMatle

    KMatle Expert Licensed User

    Please uninstall all previous versions. Did you check, that the package-names must be different between apps?
     
    lemonisdead and DonManfred like this.
  4. DonManfred

    DonManfred Expert Licensed User

    Did you changed the packagename (most used curlpit) in your new app. It is named B$A Example by default...
     
    KMatle and lemonisdead like this.
  5. Arun

    Arun Member Licensed User

    I checked all the suggestions above and re-tried. No luck.

    @Erel, I am using B4A Bridge in Wifi mode.

    @KMatle, There aren't any previous versions of the App. This is a new app. I changed the Application Label on Line 2 of the project. Is there any other place where the app name needs to be set.

    @DonManfred: I changed the Application Label on Line 2 of the project. Is there any other place where the app name needs to be set.

    Thanks to all of you for the prompt replies!
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    Try to change the package name (Ctrl + B).
     
    Arun and lemonisdead like this.
  7. DonManfred

    DonManfred Expert Licensed User

    CTRL-B
     
    Arun and lemonisdead like this.
  8. Arun

    Arun Member Licensed User

    :) Thanks! New App got installed!

    Now I will check my other apps.

    Just a question - Why doesn't B4A Example show up in the Apps list? That would probably have given me a clue.

    I had earlier uninstalled all the apps installed with the Trial Version, but B4A Example is not shown.

    Does it mean an app with the name B4A Example is still existing on the device?
     
  9. Arun

    Arun Member Licensed User

    Thanks! The app got installed!
     
  10. DonManfred

    DonManfred Expert Licensed User

    a new project will become a packagename b4a.example and the label will get B4A Example
    You need to change both for every new app
     
    Arun and lemonisdead like this.
Loading...