Android Question not show layout in emulator

omidaghakhani1368

Well-Known Member
Licensed User
Hi Erel.
I have a hug problem.
when i open designer and add view into layout,not show any change of view in emulator or other emulator or even in my phone.
but when compile my project,it's solve and show layout successfully.
do sdk have problem or basic4android or emulators?
 

lemonisdead

Well-Known Member
Licensed User
Hello,

If you use the Designer Scripts to place your views, you will only see them moving when you open the "Designer Scripts" tab. Or else, they will be placed with fix dimensions and spaces like you see them under the "Main" tab. Hope this could help.

Edit : if you use Variants you will have to have different Emulator's variants too (as you can only see one at a time)
 

omidaghakhani1368

Well-Known Member
Licensed User
Hello,

If you use the Designer Scripts to place your views, you will only see them moving when you open the "Designer Scripts" tab. Or else, they will be placed with fix dimensions and spaces like you see them under the "Main" tab. Hope this could help.

Edit : if you use Variants you will have to have different Emulator's variants too (as you can only see one at a time)
it test it but again not show changing view in emulator
 

klaus

Expert
Licensed User
You need to give more precice information on what exactly you are doing.
When you run the Designer is the AbstractDesigner displayed ?
How do you add the views ?
Do you have several alyout files and is the correct one displayed ?
Do you connect your device or emulator to the Designer ? etc.
Lots of questions you need to check or answer !
 

omidaghakhani1368

Well-Known Member
Licensed User
OK.
I add view into layout and move it in abstract designer but in emulator not move and when compile it,solve :)
 
Top