Bug? Not sure if it might be an Android 4.4.4 bug regarding hint text

jlperez

Member
Licensed User
We have an App working as expected in Android 4.3.x in a Samsung Galaxy SIII device. Now we've testing it on a pure Android 4.4.4 device such as BQ AQUARIS E5 4G and we are experiencing some weird behaviour. When a text edit field which has a hint text receives focus the hint text does not dissapear.

Is anybody else noticing this?

Thanks for your help.

Best regards
Jose Luis.

issue-with-hints.png
 

jlperez

Member
Licensed User
Is not a valid assumption Erel. In the login page I'm doing some webservices call to sync data and when finishes OK then I'm calling Activity.LoadLayout("Login") just in one part of the code. The JobDone.

Best wishes for 2015 and thank you for your help.
 

jlperez

Member
Licensed User
You're right as always Erel. The trouble is in my code. I clean most of the project to focus on hint problem. I did a previous test commenting the code used to synchronize DB and put the Activity.LoadLayout("Login") (which is placed in JobDone method) in Activity_Create method. Doing this it works in Android 4.4.4 (also in 4.3). The problem in Android 4.4.4 seems to be where to place the LoadLayout call.

Thank you in advance.

Jose Luis
 

Attachments

jlperez

Member
Licensed User
However the behaviour in Android 4.3 is pretty different since Hints works perfect with the same code.
 

jlperez

Member
Licensed User
Finally I've found some simple workarround that works. Just setting the background color it fixes the strange behaviour I found.


Label3.Typeface = SignikaBold
UserName.RequestFocus
' Color para los campos de login y disimular el bug del hint
UserName.Color = Colors.DarkGray '.Black
PassWord.Color = Colors.DarkGray ' Black
 
Top