Optimized compilation

Discussion in 'Questions (Windows Mobile)' started by susu, May 12, 2008.

  1. susu

    susu Well-Known Member Licensed User

    I write a Windows app and compile with "Optimized compilation". But when I run, it's nothing happen. I compile again without "Optimized compilation" and it's ok.

    What's wrong?
     
  2. Cableguy

    Cableguy Expert Licensed User

    Too litle info.....

    What is it supposed to do?
    Can you post your code?
    Are you using any dll?

    The amount of info provided is the only thing that helps us to help other...
    Just saying "I have a problem" does not help us, help you....
     
  3. susu

    susu Well-Known Member Licensed User

    Dear Cableguy,

    I write a Windows app use some libraries. When I run (F5) to test, it's OK. I compile with "Optimized Compilation" it's creat a .exe file but when I run, there's nothing happen. I compile again without "Optimized Compilation" and run .exe file, it's OK. I don't know what going on. Can you explain? Thank you.

    Ps: Sorry for my bad English.
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    Can you upload your source code?
     
  5. Tirs

    Tirs Member Licensed User

    Optimized compilation - device EXEs just do nothing

    Hello. Sorry for recovering an old thread, but it describes exactly my problem and I found it "cut in the middle"; let's see if we can give it a happy end ;)

    Basically the problem is: if I compile a device EXE without the "Optimize" option, the program works fine; if I compile the same with "Optimize", then the executable ignores the stylo tapping and does not run at all. No reaction, no error message, nothing. This happens with all the programs I tried: my own programs, a sample grabbed from the website ("GPSExample.zip") and even a test program I just prepared.

    The thread ended with Erel asking Susu to upload the source code. Well, I prepared a very simple bare-bones program: it displays Form1 with a text and a button; when the user clicks the button, the program ends. I'm also sending both device EXEs, optimized and non-optimized. The second behaves as expected, but the first doesn't even start, as I'm explaining.

    I'm using B4PPC version 6.50, and my device (Acer n35) runs Windows Mobile version 4.20.0; the processor is a Samsung S3C2410 (which means, StrongArm type).

    Hope someone can :sign0085: me!
     
  6. digitaldon37

    digitaldon37 Active Member Licensed User

    Hi. Does the Samsung S3C2410 have Compact Framework 2.0?
     
  7. Cableguy

    Cableguy Expert Licensed User

    The Compact Framework is NOT cpu related, but WinMobile version related....
    SO, did you mean to ask if the Acer n35 has CF2.0?
    Being this a WM5 device, if it does not have already in ROM, it can be installed as a seperate pakage...
     
  8. digitaldon37

    digitaldon37 Active Member Licensed User

    I was not asking about the CPU, I was asking about the version of Win Mobile that was on his device. I did not see where it was mentioned that it was a WM5 device.

    I had not heard of Win Mobile 4.20.0 and I was curious if CF2.0 was installed.
     
  9. Tirs

    Tirs Member Licensed User

    Is there a Compact Framework 2.0 for Windows Mobile 4.2?

    Sorry for the days off... my PPC died misteriously and I had to take it for repairs, so I didn't do anything related to it (even connecting here --sorry).

    Well, it turns out that CF 2.0 was not installed in my PPC. If I recall correctly, it was installed before, but a few months ago it went through a cold reset, so it might happen that I didn't reinstall everything. But I went to the Microsoft web site, and it looks like CF 2.0 requires Windows Mobile 5 or newer (it refuses to install complaining about OS version). Can it be that my memory is playing tricks on me?

    Anyway, it looks like my problem is that I don't have Compact Framework 2.0, but I cannot find a package for Windows Mobile 4.20. Anyone can confirm me if it exists, and where to find it if it does?

    Alternatively, is there any way to use the GPS/Serial features of Basic4PPC without optimised compilation?

    Thanks in advance!
     
  10. Erel

    Erel Administrator Staff Member Licensed User

    Windows CE 4.20 doesn't support .Net CF 2.0.
    You can replace Serial2 with SerialDevice and SerialDesktop. These libraries don't require .Net CF 2.0.
     
  11. Tirs

    Tirs Member Licensed User

    It seems to work now!

    Well, now I'm able to open the serial port and get "something" from the GPS. Whether it's garbage or some actual data, it's for me to investigate and find out.

    Thanks a lot for your help, Erel!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice