Android Question Parsing the package - error

Discussion in 'Android Questions' started by daniedb, May 31, 2015.

  1. daniedb

    daniedb Active Member Licensed User

    Hi Guys

    Working through Erel's Tutorial on google Maps V2

    When compile and upload to Phone (B4A Bridge, Wireless) I get a error on the Phone:
    Parse Error
    There is a Problem parsing the Package

    Tried on 2 Different phones with the same error.
    Even Copied the APK and try to inatall Manually on the phone with the same error

    Ideas?

    Thanks
    Danie
     
  2. KMatle

    KMatle Expert Licensed User

    Have you turned off "Allow installation of apps from Unknown Sources"?
     
  3. daniedb

    daniedb Active Member Licensed User

    Yes I did. All other packages install fine.
    I start with Erel's Google Map Tutorial V2, and when I try that install it give me the error
     
  4. Erel

    Erel Administrator Staff Member Licensed User

    Which device are you using? GoogleMaps require Android 4+.
     
  5. daniedb

    daniedb Active Member Licensed User

    Samsung S5 and SamSung Galaxy Tab 7. Both are running Android version > 4
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    You will need to use usb debug mode instead of B4A-Bridge. Hopefully it will provide more information about the problem.
     
  7. Andrew (Digitwell)

    Andrew (Digitwell) Member Licensed User

    Hi.
    I know this is a bit of an old thread, but I ran into exactly this same Parse error problem when I tried the map example.

    I found a solution here: https://stackoverflow.com/questions/14832911/android-map-v2-why-maps-receive-permission

    I commented out the reference in the manifest to MAP_RECIEVE and it worked.

    Code:
    'AddManifestText( <permission
    '  android:name="$PACKAGE$.permission.MAPS_RECEIVE"
    '  android:protectionLevel="signature"/>
    '  <uses-feature android:glEsVersion="0x00020000" android:required="true"/>)

    AddApplicationText(<meta-data
      android:name=
    "com.google.android.maps.v2.API_KEY"
      android:value=
    "AIzaSyBZ6F5XXXXXXXXXXXXXXXXXXXX"/>
       <meta-data android:name=
    "com.google.android.gms.version"
       android:value=
    "@integer/google_play_services_version" />)
    I hope this helps some other newbies.

    Andrew
     
  8. ibs06t

    ibs06t New Member Licensed User

    hi

    im using lenovo vibe k5 5.1.1 phone
    and complie the code and i get an error (There is a Problem parsing the Package)
    but android version 6.0 working correctly.

    how to solve the problem....?
     
  9. Erel

    Erel Administrator Staff Member Licensed User

    Did it start after you added Google Maps?
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice