Android Question Problem between HttpUtils2 and OkHttpUtils2 & android versions


Active Member
Licensed User
Longtime User
I have an app that logs onto a secure company site, last week the authentication server was changed to a 'NetScaler AAA' system and my app using HttpUtils2 would not work returning the following error: "org.apache.http.client.ClientProtocolException" I updated to OkHttpUtils2 and it works fine on newer versions of android but on older versions (I have a report from android 4.2 with a fail) the following error is returned " SSL handshake aborted: ssl=0x37a100: I/O error during system call, Connection reset by peer".
Is there a minimum android required for OkHttpUtils2?
I also tried using a "WebView" container (with zero size and hidden in the background) to do the login using javascript and this worked for all versions of android but takes quite a while as each section of the login procress has to wait for the "Webview_PageFinished" before triggering the next stage.
Any suggestions?


Well-Known Member
Licensed User
Longtime User
I wonder if your root certs need updating? I know with windows you have to keep your root certs up to date, or the SSL/TLS system will bark at you.
Upvote 0