"Process is running longer..."

nfordbscndrd

Well-Known Member
Licensed User
My app has a 15MB data file (which is going to double or triple in size before I'm done). I've had a lot of trouble getting the app to load into the emulator, so I stripped the program code down to almost nothing. Still wouldn't load. I removed the data file and it loads. Put it back in and I get the "Process is running longer than expected" message, so the data file looks to definitely be the problem. (I've also tried with a small data file and it loads okay.)

Some times when I say Continue it never finishes and says there was a time out; other times it will finish loading.

Is B4a and/or the emulator just not designed to take a large data file?
 

TOB

Member
Licensed User
I just had the same problem with a large application i'm making. First it came out with the process timeout as nfordbscndrd mention. Lately (as I added more to the source) it has resulted in "install_failed_insufficient_storage".

What I did to solve the problem was to increase the ProcessesTimeoutSeconds setting from default 30 to 300 sec (I don't mind waiting). I also unchecked the "Can install to external storage" and enabled "Wipe user data" in the AVD Manager / Emulator.

I did a Alt-3 and it worked like a charm. Checked the "Can install to external storage" afterwards again and did a new Alt-3 without any problems.

Hope you can use the same M.O.

Edit:
To set the ProcessesTimeoutSeconds value you will need to edit the INI and set it to Read-Only afterwards. Then quit the IDE (it will flash an error) and start it again. After the IDE is running you can remove the Read-Only from the INI file.
@Erel: It would be nice to be able to set the ProcessesTimeoutSeconds value from the IDE.
 
Last edited:

Erel

Administrator
Staff member
Licensed User
Instead of changing the ini file to read only you can first close the IDE and then edit the file (the ini file is written when you close the IDE).
The ini file on Vista / Windows 7 is located under: C:\ProgramsData\<user>\Roaming\Anywhere Software\Basic4android.

@Erel: It would be nice to be able to set the ProcessesTimeoutSeconds value from the IDE.
It will be added.
 

Cor

Active Member
Licensed User
When using larger screens 1024 and higher i get always timeout

When will this be added in IDE?

And is it possible to change it manually?
 

Erel

Administrator
Staff member
Licensed User
And is it possible to change it manually?
You can change the ProcessTimeoutSeconds value in the ini file. It is located:
XP: C:\Documents and Settings\<user>\Application Data\Anywhere Software\Basic4android
Vista / 7: C:\Users\<user>\AppData\Roaming\Anywhere Software\Basic4android

Make sure to close the IDE before doing any change.
 

Cor

Active Member
Licensed User
Vista / 7: C:\ProgramsData\<user>\Roaming\Anywhere Software\Basic4android
Not found for windows 7

on XP in file was detected
 

Robcom69

Member
Licensed User
Thanks Erel, I found the INI file and change it in this way:
MaxRamForDex=1024
UseOptimizedDexer=False

Nothing to do. I always receive a TimeOut error. Tried to increse the TImeOut but still the same error...
I really disappointed. I never had this problem,. It raise when I start using Google Maps (using your tutorial).
Is it normal ?
Or maybe is my Notebook that is too old (a HP Pavillon ZV5000 with only 1 GB of RAM) ?
 

Robcom69

Member
Licensed User
Thanks for your precious infos. I'll try again as soon as possible but maybe is better for me to buy a new notebook :)
 
Top